SAFE Banking Protection wont' load

Highlighted
Scholar

SAFE Banking Protection wont' load

It's odd.  Yesterday my banking protection worked.  Today it doesn't.  I don't have an option to turn it on.  Anyone have advice? 

1 ACCEPTED SOLUTION

Accepted Solutions
Superuser

Re: SAFE Banking Protection wont' load

The first thing I would try is to reinstall the browser extensions from the Browsing Protection screen, followed by a reboot.

The next step would be to try a different browser and see if the issue still remains. If BP then works, perhaps your original browser has had an update which has knocked out the Browsing / Banking protection?

If none of the above does any good, then try reinstalling F-Secure.

Let us know how you get on. :)
3 REPLIES 3
Superuser

Re: SAFE Banking Protection wont' load

The first thing I would try is to reinstall the browser extensions from the Browsing Protection screen, followed by a reboot.

The next step would be to try a different browser and see if the issue still remains. If BP then works, perhaps your original browser has had an update which has knocked out the Browsing / Banking protection?

If none of the above does any good, then try reinstalling F-Secure.

Let us know how you get on. :)
F-Secure

Re: SAFE Banking Protection wont' load

Hi

 

If you have Windows 8 or newer, please open task manager and go to "Startup" tab. Make sure you have not disabled "F-Secure Host Process". That is the user interface of our product and if it's disabled, you will not receive any notifications.

 

Ville

(F-Secure R&D)

 

Scholar

Re: SAFE Banking Protection wont' load

Looks like reloading the extension worked.  Thanks.  I also had to sign into Chrome for it to work.