My SAFE experience

Superuser

My SAFE experience

I am a beta tester for F-Secure, but have just transferred one of my devices to F-Secure SAFE.  To test out the installation, I thought I'd try to be 'difficult', so after creating my account and logging in, I tried to download and install FSIS without first removing the beta version.  Upon entering my device name, I received the ever so helpful, but popular, "ERROR - Please try again later" message box.  Que?  dunno.gif  It would have perhaps been useful to have been told what the 'error' was, but nevertheless, I assumed it was because I hadn't removed FSIS Beta.  So, I uninstalled FSIS beta using the FS Uninstallation Tool, rebooted, and tried again.  "ERROR - Please try again later".  Bugger! 

 

I then checked Windows Updates, and sure enough, there were two waiting to be installed, so I did that, rebooted again (always a good idea after updates), and went back to the SAFE portal.  "ERROR - Please try again later".  

 

So, what could it be?  I even uninstalled MalwareBytes, in case it was that (even though it's supposed to be compatible), but still no joy, then, as a last resort, I just wondered if it would work if I tried using Internet Explorer - Bingo!    My default browser is SeaMonkey, which I know nobody uses, but I do, and have done for 14 years, so I'm not about to change it now!  It seems that the SAFE download thingy doesn't like certain browsers.  I haven't tried it in Firefox, but if anyone has problems with the dreaded "ERROR - Please try again later" message, try using IE to install SAFE.

 

Now it's installed, up and running, and updating, so I'm a happy bunny, but FS need to work on their error messages!  :)

10 REPLIES 10
Advocate

Re: My SAFE experience

Great work Simon! I'm about to try SAFE myself so I'll test some other browsers and get back.

Superuser

Re: My SAFE experience

Nik, see if it will install without first removing the Beta.  :)

Advocate

Re: My SAFE experience

I don't have beta and only tried a full install on a Mac. I already have Internet Security on my PC so on that I only tried until the install started and the window "Welcome to F-Secure setup" appeared, then I cancelled. Coming that far at least assures no "ERROR - Please try again later".

 

I tried the SAFE portal from the following browsers:

  • Internet Explorer 11 - OK
  • Firefox 26 - OK
  • Opera 18 - OK
  • Safari 6.1.1(Lion, Mountain Lion) - If the Safari settings are set to block cookies from 3rd parties you get a message about not accepting cookies from iframes. Without solving that the section with all the install options won't be displayed. When solved everything was OK.

So if you log in to SAFE but don't see the Install options, verify your browser settings that cookies from 3rd parties are accepted. Or try with a different browser.

 

Another thing I noticed was that if you go to the portal with /login in the address but you're already logged in there, it will ask for log in credentials. So instead of going to https://mysafe.f-secure.com/login it's better to always use https://mysafe.f-secure.com/  

If you're already logged in you'll automatically see your SAFE page. If you're not logged in you'll be redirected to the log in page.

Superuser

Re: My SAFE experience

Good observations, Nik. :)

So, it seems that so far, it's only SeaMonkey that it doesn't like. Has anyone tested with Chrome? Maybe it's something to do with a browser plugin? I noticed that IE flagged something up about Java, which perhaps isn't installed on my SeaMonkey. Would Java be a requirement for the installer to work? If so, then, again, it would have been helpful for the error message to say so, rather than just to "try again later". :)
Advocate

Re: My SAFE experience

Java is not required. I don't have it on any computer. (not to be confused with javascript)

 

It can be a problem with a specific browser/version, plugin/addon + version, browser setting, https/certificate setting, OS etc. Well, a lot of things Smiley Wink But whatever the reason is, the message should be changed to better describe the reason behind it! 

 

Maybe @Blackcat can verify Chrome, or perhaps he already did?!

Highlighted
Community Manager

Re: My SAFE experience

Good Morning,


Thank you both for your feedback.

 

SeaMonkey is indeed a browser we haven't tested (and can't support).

 

Chrome works, that has been verified.

 

Can you confirm the error message appears in the iframe? (Tokens/Installation selection) or is it more of the portal giving that error?

 

Cheers,
Stephan

Has somebody helped you? Say thanks by giving kudos. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.
Superuser

Re: My SAFE experience

HI Stephan,

 

I'm not quite sure what an iFrame is, but the error appears immediately upon clicking Add when inputting the device name.  Screenshot below:

 

Untitled.png

 

I think the main issue is that the message doesn't actually tell the user anything useful, and if the browser is not compatible, telling the user to try again in a moment is not particularly helpful, as this could imply a server / connection issue.

Community Manager

Re: My SAFE experience

Hi Simon,

 

OK, now I know where exactly it comes from, thanks!

I believe the message was meant for actual connectivity issues but your specific browser seems to trigger it.

 

Will forward the feedback on error messaging.

 

Cheers,

Stephan

 

Has somebody helped you? Say thanks by giving kudos. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.
Superuser

Re: My SAFE experience

Hi Stephan,

I can't find the specific threads / posts at the moment, but we have had other users posting with that same error message. I'm not sure if they were using SeaMonkey, but I doubt it. I don't think we ever got to the bottom of the issue with some users.

Just out of curiosity, what is it about SeaMonkey that makes it incompatible?