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License information missing in F-Secure Internet Security/Anti-Virus 17.5

Symptoms

You cannot find your license information in Internet Security or Anti-Virus version 17.5.

Diagnosis

Currently, there is no way for you to see the license information in the product. This feature will be reintroduced into the product soon.

Solution

To gain access to your license information for this version (17.5), do as follows:

  1. Find your Account ID number:
    1. Right-click on the F-Secure icon in the system tray.
    2. Select Open common settings.
    3. Click on Identity codes.
    This shows your personal Account ID number (in the following format: XXXX-XXXX-XXXX-XXXX-XXXX).
  2. Contact Customer Support and give the agent the Account ID number.
Pricing & Product Info

For product info and pricing please go to the F-Secure SAFE product page

Version history
Revision #:
2 of 2
Last update:
2 weeks ago
Updated by: