Lag in completing installation and detecting Eicar files on first install.

Advocate

Re: Lag in completing installation and detecting Eicar files on first install.

@Simon "my FS has never blocked a website I've visited due to it being unsafe"


Are you sure? I thought the same too, yet I have blocked sites in the statistics for Online Safety:

F-Secure > Online Safety > Settings > Statistics

 

Maybe FS doesn't always notify you. My guess is that FS only notifies you if the url in the address field in the browser is malicious, not if an iframe or script inside the webpage refers to a malicious site.
This is just a guess, does someone else know more about this?

Superuser

Re: Lag in completing installation and detecting Eicar files on first install.

@ Blackcat - I've never moved from the beta releases. Now on TP96, I believe.

@ NikK - I'll check when I'm back on the computer later, but I'd be surprised if had blocked anything, as I don't tend to visit 'dodgy' websites, and usually stick to my known regulars. That's not for any puritanical moral reasons - I've just been there, seen it and already had the viruses years ago - lol - so I just tend to play safe nowadays. :)
Senior Advisor

Re: Lag in completing installation and detecting Eicar files on first install.

Installed F-Secure IS 2014 official version on a new snapshot; obtained some detailed logs on the update.

 

1. After 10 minutes, pop-up Window said that FS had installed successfully, and Status Window stated that "your computer is protected". No Reboot window, so left program just sitting there waiting for the remaining updates. 

 

2. Nearly 15 minutes later, the Aquarius update had finally installed-so now we have FULL PROTECTION. 

 

Capture 2.GIF

 

 

 

So 15 minutes after the Status Window had shown that your computer was protected then we finally receive the last update-Aquarius-and we are now, finally fully protected.

 

This disparacy needs to be reflected in the Status Window during the update procedure, IMHO. The Status Window needs to confirm full protection only after the final update. 

Superuser

Re: Lag in completing installation and detecting Eicar files on first install.

I've just had a beta upgrade, which I did through the program, and I did receive a reboot prompt (poorly displayed):

 

Restart.png

 

The Aquarius update came in two minutes after Hydra.  I think this has already been established, but this does just show that the initial installation, and subsequent upgrades are handled differently.  If there is no reboot prompt after initial installations, then this is a serious flaw, in my opinion, as the reboot would presumably prompt the remaining database updates to enable full protection.  Without this, I have to agree that security appears to be compromised for the time it takes for Aquarius to fully update.

 

Untitled-1.png