cancel
Showing results for 
Search instead for 
Did you mean: 

F Secure when trying to activate after installation get Check Network connection

Novice

F Secure when trying to activate after installation get Check Network connection

Tried help line  no help really did not seem to have any answers.

 

Gave up so seeking help here.

 Installed via Google Playstore  on  on tablet/mobile phone ok..

Icon for activation on tablet screen

Log on accepted. Then " check network connection and try again".

 

I did this several times to no avail.

Any help please.

14 REPLIES
Community Manager

Re: F Secure when trying to activate after installation get Check Network connection

Hi Labby,

 

I managed to find your case opened with our Support team and update them about this Community post. They are checking on the case and will be responding back to you about the further steps.

 

 

Has somebody helped you? Say thanks by giving likes. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.
Novice

Re: F Secure when trying to activate after installation get Check Network connection

Any solution to this yet

Novice

Re: F Secure when trying to activate after installation get Check Network connection

I have just subscribed for a year to F Secure Safe and trying to install on my Samsung Tab A (Android 6).  All accounts were set up straight forward, until I download the android app.  Having moved past the initial screen, I also get the "check your connection and try again" message.   My connection is over 100 mb/so it's not that.  Have also uninstalled and tried again, but to no avail.

 

Any Ideas?   

Novice

Re: F Secure when trying to activate after installation get Check Network connection

Hi, did you ever sort this? having the same problem. Thanks 

Community Manager

Re: F Secure when trying to activate after installation get Check Network connection

Hello Everyone,

 

I found an article related to the connection issue. Could you please check this article which has some steps outlined?

Has somebody helped you? Say thanks by giving likes. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.
Scholar

Re: F Secure when trying to activate after installation get Check Network connection

I have just got 1 years subscription for 5 devices. Installed on my laptop with no problem. Then installed on phone (samsung galaxy s7 edge) and every time i try to log in it tells me to check my connection and try again.

 

I'm connected to my home networks virgin media cable connection. And the same message comes when I'm connected to my 4g network on EE. 

 

Please advise? I have no problems connecting to the f-secure https test page on both connections. 

Scholar

check your connection, android nougat v7.0

ive sent several emails and asked for help in other sections to absolute no response at all, its like you guys have no after sales support what so ever..

 

anyway, i have 1 year subscription with 5 licenses, i activated 1 licece for safe on my laptop (windows 7) then i tried to use another on my samsung galaxy s7 edge, every time i try to log in it tells me to check my connection, i have tried 5 different wifi networks and 2 different mobile carriers 4g connections, and it will always tell me to check myconnection. 

 

hopefully ill get some support on here so far im extremely dissapointed with this comapny

Scholar

Re: F Secure when trying to activate after installation get Check Network connection

seriously? no reply at all.. all i see on  the play store is 1 star reviews with people with this exact same problem.. its like there isnt nothing there to connect too.. it has nothing to do with our connections.. f-secure are not giving me any support what so ever on this.. really awfull aftersales support.. ive emailed 3 times and posted here but not a single message or response 

 

please advise.

Superuser

Re: F Secure when trying to activate after installation get Check Network connection

Did you check the article linked to above?

 

https://community.f-secure.com/t5/F-Secure-SAFE/I-am-unable-to-connect-to-the/ta-p/15794

 

 

This issue does seem to be related to Samsung phones.  Maybe they have something in their software which is causing this?  If you've not already done so, I suggest you send in a Support Ticket, and hopefully you will get a response.