F Secure Setup fails at License Terms screen with "Download Failed"

SC
Scholar

Re: F Secure Setup fails at License Terms screen with "Download Failed"

Hi,

 

The ID ref is 00118221

 

Thanks

SC
Scholar

Re: F Secure Setup fails at License Terms screen with "Download Failed"

Can any one help ?  Am I alone with F Secure won't work with XP ?  Has this been tested ?  Help Please

Advocate

Re: F Secure Setup fails at License Terms screen with "Download Failed"

I have actually no idea if .NET framework updates has anything to do with this problem or not, but you said that KB2835393 was the latest update, and from September. That update was actually released in July, and there are several other updates released even for XP after that one. That makes me think if you perhaps have a problem with Windows itself.

 

Are you able to install any other program at all? Just thinking if it could be a problem with the Windows Installer (4.5 is the latest for XP)

Besides that there are several Microsoft FixIt programs related to installation issues and problems with Windows Update, but I don't think you should run any of these if the problem only is related to installing the F-Secure product.

 

You could also verify that you had several new windows updates installed within the last 2 days. Check the Windows Update history to see if Windows Update is working as it should.

 

The biggest difference with OnlineScanner it that it's a single executable file, not an installer. It's a big difference! That's why I think you should try and install any other program just to see if it's perhaps a general problem with installing applications. I've actually had that problem once and re-installing the Windows Installer solved the problem.

 

There are other users running XP with no problem including SAFE customers coming from Virgin Media. The general problem for VM customers was that VMS was not completely removed which caused errors when installing F-Secure, but after running the specific VMS Removal Tool it installed OK.

 

Note that Microsoft soon is ending its support for XP including all security updates. I would not recommend continue using XP after April 8.

http://community.f-secure.com/t5/Security/Running-Windows-XP-Microsoft/td-p/44791

Superuser

Re: F Secure Setup fails at License Terms screen with "Download Failed"

Sorry if you already did it, but I not totally understand that points:

 

 - what about "uninstallation tool" by F-Secure (or by F-Secure; or Virgin Media supported by F-Secure)

It's another tool, which need to download and use it after uninstallation by default-steps (in Windows Control Panel) by hand - if it's have something here;

 

 

 - what about "firewall"? it's totally no one except default Windows Firewall?

And what mean "not running" - can it's mean that "installed, but turn off/not running" another firewall (not a default by Windows);

 

------------------

Simply that two points..... more commonly troubles with installing in Windows XP for F-Secure;

 

First point - it's can break new installation - if something wrong; Probably.... it's can be another programs (before) - which can to clean by utilities (it's can be previously antviriuses or another protect-programs);

And except "cleaning" - also can to help clean by F-Secure Uninstallation Tool;

 

Second point - if in system have another firewall (not by Windows as default) - it's can blocking downloading/installation/verification for F-Secure; Anyway; It's can be without any hard steps; It's just can be;

 

--------------------------------------

If you already have experience about F-Secure Uninstallation Tool; And system without any firewalls (except default Windows) in status "installed"; Or another same programs  - I need to say "sorry!" , because take your time.

--------------------------------------

 

It's mean except all previously tips and recommends... can just give suggestions like:

 

 - maybe trouble in another configure with network connection (as router-firewall or some kind of); also some points already was here about it too;

 

 - what about viruses in system?

Try to use F-Secure Rescue CD for scan system in that way;

Scan by F-Secure Online Scanner - maybe not enough; Just because it's can break in that case or simply "be very quite" for ignore any false-positive;

Maybe need something more...

-----------------------------------------

 

And both two "points" can be in case, when F-Secure Online Scanner launched.

In my experience  - trouble in firewall more often to meet with Windows XP and same installers; It's mean - if firewall not default by Windows - just turn off - can be not enough in some case.

 

Also as else one variant:

 

Can you try to install trial version F-Secure IS - not by or "as Virgin Media costumer";

If it's possible - just from official page about F-Secure Internet Security in official website - check a "trial version" and try to install it.

 

------

 

Also forget to ask:

 - what about any virtual program in system - such as famous VirtualBox (and same) or another "way"-program as "Shadow Defender" (and same)?

Or another things, which can be work in system with same behavior or "previously" was.

F-Secure

Re: F Secure Setup fails at License Terms screen with "Download Failed"

Hi SC!

Since there haven't been any recent comments from you, so can you tell us if you are still having these problems?

Thanks!

// Chrissy
Has somebody helped you? Give Kudos as a way to say "thanks!"
Has your issue been solved? Mark the post using the "Accept as Solution" button to let others know.
SC
Scholar

Re: F Secure Setup fails at License Terms screen with "Download Failed"

Hi Chrissy,

 

I have been dealing with customer care at F Secure recently; they have been a bit more responsive since my moan on this forum.  However, they have still not sorted this out and I am getting very fed up.

 

All I want to do is install their anti virus program, it can't be that difficult can it ?

 

Thanks.

Advocate

Re: F Secure Setup fails at License Terms screen with "Download Failed"

SC, it seems you have encountered a very unusual problem. That's why I think you should:

 

1. Verify that Windows Update is up-to-date.

2. Verify that you can install any other program.

As I mentioned before, your latest update for the .NET Framework is in fact not the latest update. So I suspect it might be a Windows problem. See my previous post for more info.

 

3. One more thing you could try is to change the value(checkbox) for Do not save encrypted pages to disk in Internet Explorers Advanced settings. I've read about strange cases where some users needed to enable this setting in order be able to download files over HTTPS, even though the normal thing is to not have this setting enabled for that to work.

SC
Scholar

Re: F Secure Setup fails at License Terms screen with "Download Failed"

Hi,

 

I have just downloaded and installed the latest .NET framework for XP, but that didn't fix my problem.  I can install other programs for instance I installed the latest ITunes update all OK.

 

My latest Windows Automatic update was on the 7 Feb 2014.  However I did try to manually install windows updates using the "express" button and I got an error [Error number: 0x80090008].  Is this relevant ?

 

Thanks

Advocate

Re: F Secure Setup fails at License Terms screen with "Download Failed"

Ok.

I "think" you should have Windows Updates from latest "patch tuesday"(11 Feb) but I'm not sure. It's not that easy to check for only XP.

 

Can't say if the error is relevant or not, but when you run Windows Update manually on XP it requires Administrator rights. Even if you're logged in as Administrator, programs like Microsofts DropMyRights can restrict that for example when a browser is launched. If you don't have any such restrictions program and you're already running as Admin, then I suggest you post in a Microsoft forum. Here's an old example about the exact same problem.

(hopefully the automatic windows update still work and this is only a manual error)

 

Did you try my 3rd advice with changing the setting Do not save encrypted pages to disk?

 

Also I recommend you scan your computer with these two scanners as sometimes strange errors can be caused by infections:

http://www.microsoft.com/security/scanner/

https://www.malwarebytes.org/free/

Advocate

Re: F Secure Setup fails at License Terms screen with "Download Failed"

SC, any progress? Did you try my suggestions?

 

Where did F-Secure go? The support ID is 00118221 and @kvick was going to check it out but hasn't logged in for 2 weeks.

Anyone else, @Ben? It's been more than 4 weeks now and F-Secure still won't install Smiley Embarassed   I've tried contributing with general Windows troubleshooting in case it's not only related to F-Secure, because I don't have any more suggestions for this error.

 

Thread summary:

  • XP SP3, SAFE through Virgin Media
  • When launching the installer and asked to select language and then clicks install button: "Download failed. Check that your network connection is working and try again"
  • No other security software running
  • FS log says: (FILE) FileAccess https://666.spi.f-secure.com/packaging/services/spi/stubconfiguration?operatorId=666&version=55 -> 'E:\Documents and Settings\All Users\Application Data\F-Secure\MySA\Downloads\stubconf.xml' (0 retries) [HTTP 0][Win32 2148073480] in 266ms (0 bytes -> 0kB/s)
  • The above https url is accessible from the same PC when manually testing it in the browser
  • @Ville thinks it's a "problem with crypto library verifying the SSL connection"
  • Followed supports advice to set IE as default browser, reset Internet Options, flush DNS, verified TCP/IP settings
  • Verified that OnlineScanner works (although it's not an "installer" and perhaps doesn't say much)
  • Verified that it's not a general Windows problem with installing applications
  • Not fully determined but it might be a problem with Windows Update, at least when trying to run it manually