F-Secure SAFE for Android trial version not visible in My F-Secure

Symptoms

If you have a trial version of F-Secure SAFE installed on your Android device (version 15.2) from Google Play, you are unable to see this device in your My F-Secure account.

This also applies to you if you have updated your existing trial version of F-Secure SAFE for your Android device from 15.2 to 15.4.

Diagnosis

If you have a trial version of F-Secure SAFE installed on your Android device (version 15.2) directly from Google Play, My F-Secure and the SAFE app on your device cannot make a link. This situation also applies if you have updated SAFE on your Android device from 15.2 to 15.4 with a trial subscription, as you are not asked to log in to My F-Secure to validate your account credentials.

Solution

To be able to make your device visible in My F-Secure you need to:

  1. Uninstall F-Secure SAFE version 15.2.
    1. Go to the app on your device.
    2. Tap the menu in the top-left corner of your screen, then More > Uninstall.
    3. Tap OK to uninstall the app.
  2. Reinstall F-Secure SAFE with version 15.4.

    Note: When you reinstall F-Secure SAFE on your Android device, you are either asked to log in to My F-Secure, or register, if you don't already have an account.

Pricing & Product Info

For product info and pricing please go to the F-Secure SAFE product page

Version history
Revision #:
5 of 5
Last update:
‎06-02-2017 02:40 PM
Updated by: