F-Secure SAFE doesn't allow Unity3D to start

Scholar

F-Secure SAFE doesn't allow Unity3D to start

If I have the antivirus activated I get the following error from unity enigne: getthreadcontext failed fatal error in gc. When I turn the antivirus off, everything works as it should and I can open my project.

 

I have tried tweaking the firewall settings, but nothing seems to work except turning the anitvirus off, starting Unity, then turning it on again. 

 

Any help on how to fix this is much appriciated! 

 

3 REPLIES 3
Superuser

Re: F-Secure SAFE doesn't allow Unity3D to start

Hello,

 

Sorry for my reply. I'm also only F-Secure user (their home solutions);

 

Good to re-check about version for F-Secure SAFE:

https://community.f-secure.com/t5/Common-topics/How-can-I-find-out-what-F-Secure/ta-p/87491

 

If it will be something like "16.5" --> maybe it possible to try check "Compatibility mode" under DeepGuard settings. And if this is helpful --> maybe possible to exclude Unity folder under exclusion list for real-time scanning;

 

If it will be "17.0" --> maybe it possible to try exclude Unity folder under exclusion list.

 

With another meanings -> maybe good if there will be attention from official F-Secure teams.

 

Thanks!

Scholar

Re: F-Secure SAFE doesn't allow Unity3D to start

Hi! Sorry for the late reply.

 

I have tried excluding unity from the anti-virus search, unfortunately, that did not fix my problem.

 

Any other suggestions?

Community Manager

Re: F-Secure SAFE doesn't allow Unity3D to start

Hi Tjoma,

 

Please submit a ticket with the labs along with the diagnostic report (fsdiag) in order to troubleshoot further on this issue. You can open a ticket with the labs here.

Has somebody helped you? Say thanks by giving likes. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.