cancel
Showing results for 
Search instead for 
Did you mean: 

F-Secure SAFE compatible with Win 8.1 yet?

Senior Advisor

F-Secure SAFE compatible with Win 8.1 yet?

Is SAFE now compatible with WIN 8.1? (and IE11).

 

It is not listed on the system requirements page; http://www.f-secure.com/en/web/home_gb/safe

14 REPLIES 14
Senior Advisor

Re: F-Secure SAFE compatible with Win 8.1 yet?

A bump on this one.

 

But apparently F-Secure SAFE is F-Secure 2013 and not 2014.

 

Maybe this is why it is given away for free for 12 months to Virgin Media customers. If true, this is not great for those users bought/buying a new computer over the holidays with WIN 8.1.

Highlighted
Senior Advisor

Re: F-Secure SAFE compatible with Win 8.1 yet?

F-Secure 2014 or FS 2013 - doesn't matter actually, subscription is product based and not version.
Senior Advisor

Re: F-Secure SAFE compatible with Win 8.1 yet?

It does if the F-Secure SAFE is restricted to 2013 version and it cannot be upgraded.

 

As far as I know only F-Secure 2014 version is fully compatible with WIN 8.1 (IE11).

Advocate

Re: F-Secure SAFE compatible with Win 8.1 yet?

Why do you suspect it is 2013? I can't find any information about versions, indicating it would be the latest. If not, it sounds almost like a kind of ISP version. And you can't upgrade ISP versions yourself from F-Secure web site.

Senior Advisor

Re: F-Secure SAFE compatible with Win 8.1 yet?

@NikK 

 

I have been in touch with a number of users over on the Virgin Media Forums who have had problems with WIN 8.1. They contacted F-Secure support and were told that the SAFE version is not compatible with WIN 8.1, as it is F-Secure 2013.

 

If they wanted to use WIN 8.1 they would have to switch to FSIS 2014.

 

Hopefully an F-Secure expert can confirm this information on the official Forum.

Advocate

Re: F-Secure SAFE compatible with Win 8.1 yet?

Oh, I see Smiley Embarassed

So is this version to be compared to an ISP version or is it perhaps possible to upgrade? (a Q to F-Secure)

F-Secure Product Expert

Re: F-Secure SAFE compatible with Win 8.1 yet?

Good morning and Happy New Year!

 

F-Secure SAFE includes the latest version, always.

Currently that is F-Secure Internet Security 2014 Release 2, which is Windows 8.1 compatible.

Best regards,
Stephan

Has somebody helped you? Say thanks by giving kudos. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.
Senior Advisor

Re: F-Secure SAFE compatible with Win 8.1 yet?

Yet another example of F-Secure Support not being consistent in their response. 

 

I have no doubt that Stephan is correct but why then is some part of the Support chain telling Virgin Media customers that F-Secure SAFE is F-Secure Internet Security 2013 ONLY! See for example; http://community.virginmedia.com/t5/Internet-security/F-Secure-SAFE-and-windows-8-1/td-p/2128364

F-Secure Product Expert

Re: F-Secure SAFE compatible with Win 8.1 yet?

Hello Blackcat,

 

Thank you for relaying this information to the Virgin Media community!

 

I'm terribly sorry about the obviously wrong communication you reported.
Sadly I'm unable to find that support request without details from the user opening that request.
So, I can't see what went wrong when, where and why.

However, I'll make sure to brief all of our customer care staff to ensure this doesn't happen again.

Best regards,

Stephan

Has somebody helped you? Say thanks by giving kudos. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.