Why doesn't F-secure key work on Chrome 32.0.1700.107 m ?

Aspirant

Why doesn't F-secure key work on Chrome 32.0.1700.107 m ?

Hello

 

I've been using F-secure key for while.

After Chrome updated itself to  version 32.0.1700.107 m

F-secure key doesn't work anymore, with following symptoms:

 

The password box opens up in top left corner and chrome selects everything and does not send correct password.

 

The only way to login with chrome is copy password from f-secure key and paste as plain text from popup menu in password field. 

IE 11 continues to work ok.

 

br,

tajuton  (= brain free)

 

1 ACCEPTED SOLUTION

Accepted Solutions
Former F-Secure Employee

Re: Why doesn't F-secure key work on Chrome 32.0.1700.107 m ?

Hey,

 

Chrome 32 update broke the compatibility to F-Secure Key's autofill functionality. Our product is not the only software suffering from this change.

 

There is a workaround to fix this. Change the Chrome browser accessibility settings:

  1. In location bar where you have the URL, enter "chrome://accessibility"
  2. On top of the page you see text "Global accessibility mode: off" (exact text may vary depending your browser language)
  3. Enable global accessibility mode by clicking the "off" hyperlink that toggles to "on".

After that Chrome 32 (and later) should work just fine. If not, please let us know!

 

There is recently opened bug report to Google about this. If you're into reading bug reports you can find it here:

http://code.google.com/p/chromium/issues/detail?id=342319

 

HTH;

Juha

8 REPLIES 8
Former F-Secure Employee

Re: Why doesn't F-secure key work on Chrome 32.0.1700.107 m ?

Hey,

 

Chrome 32 update broke the compatibility to F-Secure Key's autofill functionality. Our product is not the only software suffering from this change.

 

There is a workaround to fix this. Change the Chrome browser accessibility settings:

  1. In location bar where you have the URL, enter "chrome://accessibility"
  2. On top of the page you see text "Global accessibility mode: off" (exact text may vary depending your browser language)
  3. Enable global accessibility mode by clicking the "off" hyperlink that toggles to "on".

After that Chrome 32 (and later) should work just fine. If not, please let us know!

 

There is recently opened bug report to Google about this. If you're into reading bug reports you can find it here:

http://code.google.com/p/chromium/issues/detail?id=342319

 

HTH;

Juha

Aspirant

Re: Why doesn't F-secure key work on Chrome 32.0.1700.107 m ?

This helped. Thanks!

Regular Member

Re: Why doesn't F-secure key work on Chrome 32.0.1700.107 m ?

And after the restart of chrome, it is again toggled off. So every single time you restart chrome you have to toggle that on again Smiley Sad

Superuser

Re: Why doesn't F-secure key work on Chrome 32.0.1700.107 m ?

With Google Chrome 34 (?) that already indeed looks... like each start of browser.... that setting dropped to default.

Regular Member

Re: Why doesn't F-secure key work on Chrome 32.0.1700.107 m ?

Solution is to start chrome with "--force-renderer-accessibility" - unfortunately i havent found any other way to do this now...

Former F-Secure Employee

Re: Why doesn't F-secure key work on Chrome 32.0.1700.107 m ?

 

Edit:

disregard, hadn't read the whole thread through, just the last coupla previous ones, this was already mentioned before. 

 

Hello, you can also do it after starting chrome:

 

type: chrome://accessibility/ in the chrome address bar, and click "on" to turn it on. This seems to be a working workaround for now while waiting for chrome to fix their issue. 

 

 

Highlighted
Regular Member

Re: Why doesn't F-secure key work on Chrome 32.0.1700.107 m ?

Yes, but you have to do that every single time that you start chrome, starts to get frustrating...

Superuser

Re: Why doesn't F-secure key work on Chrome 32.0.1700.107 m ?

Yes,

 

How I can to understand for Google Chrome less than 34-version able to use "workaround" by settings (and it worked - how I remember);

But with Google Chrome 34 that "accesibility-option" with each start of browser... dropped to default (?!); Workaround work - but it's can be a little hard to do always : )

 

Possibly I not really love Google Chrome and do not often use that browser.... and just checked last words about "situation". Because probably - it's can be related already with Google Chrome 33 (if it was);

 

Anyway - looks... that previously tips about "editing"-command-line for start browser... maybe work... and can be new "current" workaround (http://community.f-secure.com/t5/F-Secure-Key/Why-doesn-t-F-secure-key-work-on/m-p/49037/highlight/t...)