F-Secure Key using too much processor time

Scholar

F-Secure Key using too much processor time

Hi guys,

 

Under Windows10, F-Secure Key quite often uses between 5 and 10% of the processor for no apparent reason and for a long duration (I mean more than 2-5 secs, which I would understand for e.g. synching tasks in the background).

 

In normal situations, it sits peacefully at < 0.5% of the processor.

 

Is it normal?

 

Best regards

G.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Executive Member

Re: F-Secure Key using too much processor time

Hi @Varkhan

 

Unfortunately, this is  a long lasting problem with Key on Windows devices! I am using Key for a long time now and on my  Windows 10 devices this 'problem' still persists! I am really annoyed because this 'high usage' of processor power triggers my fans. I am experiencing this problem on 2 Surface Pro 3 devices and on one high-end desktop PC with Windows 10. 

 

You can try to disable Key autofill functionality. Just open Key and go to Settings. This 'workaround' might help in some cases. 

 

All in all it's very disappointing that Key isn't functioning very well.

 

 

3 REPLIES 3
Highlighted
Executive Member

Re: F-Secure Key using too much processor time

Hi @Varkhan

 

Unfortunately, this is  a long lasting problem with Key on Windows devices! I am using Key for a long time now and on my  Windows 10 devices this 'problem' still persists! I am really annoyed because this 'high usage' of processor power triggers my fans. I am experiencing this problem on 2 Surface Pro 3 devices and on one high-end desktop PC with Windows 10. 

 

You can try to disable Key autofill functionality. Just open Key and go to Settings. This 'workaround' might help in some cases. 

 

All in all it's very disappointing that Key isn't functioning very well.

 

 

Scholar

Re: F-Secure Key using too much processor time

Hi @Vetraci,

 

Thanks - ok well, really nice then... that's something for the dev team to get on, if this is well known, I'm surprised they don't (or they are in the process of and don't communicate well ^^).

 

Seems to be a good workaround, the system fill is not much of use to me, as most of the passwords I use are, as I suppose is the case for most of us, for web sites.

 

Thanks again

Best regards

V.

Superuser

Re: F-Secure Key using too much processor time

Hello,

 

I just able to add my own feedback/feelings:

 

--> I used F-Secure Key maybe from first of builds (?! or one of them)  to some of recent builds;

But not really friendly with latest builds of Key - where maybe a lot of changes;

 

And it was always with this kind of "visible CPU"-usage, when it maybe unexpected. For me - it was with no so visible impact for using system (system is still responsive and other meanings); BUT there was one troublestuck (based on this "trouble" with system resources usage): freeze/unresponse for browser's pages (with certain situations and steps); It also was possible to get with system applications, but not so often; When I tried some of latest builds of Key - there was maybe much more good situation;

 

--> Since it was partly "as designed" (with my understanding) - I feel that there was some improve-steps (or tries by F-Secure Key team);

Because such "CPU"-usage triggered (?!) by real-time ability fill the data and detect that there is possible to perform "autofill";

 

So, "'workaround" (by Vetraci) with disabling system autofill (latest builds of Key) should be as proper step. Also with current design - when F-Secure Key team added browser extensions for two browsers (and their autofill-feature);

 

With disabling "system autofill" there most likely already will be not possible to use shortcuts-autofill as Ctrl+F2 (and than -> entry autofill; or SHIFT+entry for login-fill; or CTRL+entry for password-fill; or CTRL+SHIFT+entry for credentials-fill-for-certain-places); And such autofill design is "main usage" for me (since not possible to use browser's extension for autofill); So, my own workaround - just closed Key after I got credentials (which not really pretty workaround). :) Good if there will be improve-steps about this kind of perfomance (if possible to improve it);

 

Sorry for my long reply.

 

Thanks.