I can't find the renewal button in My F-Secure

Symptoms

My F-Secure SAFE (or F-Secure TOTAL) licenses are soon to expire, but when I log in to My F-Secure, I don't see how I can renew my licenses.

Diagnosis

The Renew now button has not yet become visible in your My F-Secure account.

Solution

With renewals, the Renew now button only becomes visible in My F-Secure either:
  • 45 days before license expiry, if you purchased the product online; or
  • 30 days before license expiry, if you bought the product from a retail store and have a code.

Once the Renew now button appears, log in to your My F-Secure account and renew your licenses.

Pricing & Product Info

For product info and pricing please go to the F-Secure product page

Version history
Revision #:
9 of 9
Last update:
6 hours ago
Updated by:
 
Labels (3)