Host failing to appear in PM Console

Aspirant

Host failing to appear in PM Console

I had a server which was showing up in the PM console with its correct product version but was showing as having its signatures way out of date!

 

When I checked the actual server, this wasn't the case as the FS GUI showed it was up to date and so did the logs - no connections problems.

 

Therefore, I assumed this was a PM status anomaly and removed the host from the PM console and I've been waiting for it to be rediscovered since.

 

I'm still waiting for it to appear several days later.  Is there a reason why the PM doesn't see it?  Normally, my PM even sees hosts on the network which don't have any AV on them!

 

I've even polled the PM from the server by initiating a manual update and a policy update and the logs clearly show the connection with the PM is successful too.

1 ACCEPTED SOLUTION

Accepted Solutions
F-Secure
F-Secure

Re: Host failing to appear in PM Console

Hello Rick586,

 

What versions of PM and server product you have?

Did you try to restart fsma and fsgkhs services, or symply reboot the problematic server?

Can you ping PM server address specified in Web UI General->Administration->Management->F‑Secure Policy Manager Server from it?

 

Best regards,

Vad

7 REPLIES 7
Highlighted
Scholar

Re: Host failing to appear in PM Console

I can't see this problem on my end. I simply connected it using the instructions given to me by F-Secure. It works just fine. I suggest for you to check them regarding this matter.

F-Secure
F-Secure

Re: Host failing to appear in PM Console

Hello Rick586,

 

What versions of PM and server product you have?

Did you try to restart fsma and fsgkhs services, or symply reboot the problematic server?

Can you ping PM server address specified in Web UI General->Administration->Management->F‑Secure Policy Manager Server from it?

 

Best regards,

Vad

Aspirant

Re: Host failing to appear in PM Console

Hello Vad.

 

We have 10.01 PM console and ESS & SS 9.2.

 

I've done a restart of the server and the FSMA service.

 

I didn't realise you could do a restart of the FSGKHS service and yes, I'm able to ping the PM and vice-versa.

 

Thanks.

F-Secure
F-Secure

Re: Host failing to appear in PM Console

Ok, then we need to investigate fsdiags from PM and server. Please, contact support.

Aspirant

Re: Host failing to appear in PM Console

Hello Vad.

 

Good news as restarting the services did resolve the problem on this occasion!  Why it didn't work before is anyone's guess but I thought I'd try restarting both services as you suggested.

 

As its worked, there's no need for me to put a ticket in anymore.

 

Can you tell me, I thought that restarting FSMA, restarts all F-S services including the GK, doesn't it?

 

If that's not the case, what would restarting the GK service accomplish without restarting the MA?

 

Thanks.

F-Secure
F-Secure

Re: Host failing to appear in PM Console

Hello Rick586,

 

You can notice, that stopping FSMA service doesn't affect several services of SS 9.20, like FSGKHS, FSWEBUID, and F-Secure ORSP client. The reason of such behavior is a long story.

I recommended you to restart both FSMA and FSGKHS, because in some cases restarting of FSMA only leads to FSMA-GK communication problems, shown by F-icon as malfunction state.

Restarting of FSGKHS can be used separately to solve GK specific problems.

 

Regards,

Vad

Aspirant

Re: Host failing to appear in PM Console

Hello Vad.

 

Thank you very much for the explanation as that explains a lot and also helps answer problems with exactly the things you highlight and why I've experienced certain symptoms and now, what I can do about them.

 

Many thanks again, as this forum is turning out to be an extremely useful resource and a quick way of getting to the bottom of issues.

 

Regards, Rick.