E-mail and Server Security 10.5 and Exchange 2013 SP1 Problem

Highlighted
Scholar

E-mail and Server Security 10.5 and Exchange 2013 SP1 Problem

Hello,

 

we encountered a problem with E-mail and Server Security 10.5 (inkluding Hotfix from 28.02.2014) and Exchange 2013 SP1.

After installing SP1 on Exchange - the Microsoft Exchange Transport Service stops.  

 

Log Name: Application
Source: MSExchange Extensibility
Date: 10.03.2014 08:34:55
Event ID: 1052
Task Category: MExRuntime
Level: Error
Keywords: Classic
User: N/A
Computer: 
Description:
Failed to create agent factory for the agent 'F-Secure Transport Agent' with error 'Failed to create type 'FSecure.AntiVirus.Exchange.Transport.TransportAgentFactory' from assembly 'D:\Program Files (x86)\F-Secure\Anti-Virus for Microsoft Exchange\fstragnt.dll' due to error 'type not found'.'. Please verify the corresponding transport agent assembly and dependencies with correct version are installed.

 

Log Name: Application
Source: MSExchangeTransport
Date: 10.03.2014 08:34:55
Event ID: 16023
Task Category: Configuration
Level: Error
Keywords: Classic
User: N/A
Computer: 
Description:
Microsoft Exchange couldn't start transport agents. The Microsoft Exchange Transport service will be stopped. Exception details: Failed to create type 'FSecure.AntiVirus.Exchange.Transport.TransportAgentFactory' from assembly 'D:\Program Files (x86)\F-Secure\Anti-Virus for Microsoft Exchange\fstragnt.dll' due to error 'type not found'. : Microsoft.Exchange.Data.ExchangeConfigurationException: Failed to create type 'FSecure.AntiVirus.Exchange.Transport.TransportAgentFactory' from assembly 'D:\Program Files (x86)\F-Secure\Anti-Virus for Microsoft Exchange\fstragnt.dll' due to error 'type not found'.
at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.FactoryTable.CreateAgentFactory(AgentInfo agentInfo)
at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.FactoryTable..ctor(IEnumerable agents, FactoryInitializer factoryInitializer)
at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.RuntimeSettings..ctor(MExConfiguration config, String agentGroup, FactoryInitializer factoryInitializer)
at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.MExRuntime.Initialize(String configFile, String agentGroup, ProcessTransportRole processTransportRole, String installPath, FactoryInitializer factoryInitializer)
at Microsoft.Exchange.Transport.Categorizer.MExEvents.Initialize(String configFilePath)
at Microsoft.Exchange.Transport.Components.CategorizerMExRuntimeLoader.Load()

1 REPLY 1
F-Secure
F-Secure

Re: E-mail and Server Security 10.5 and Exchange 2013 SP1 Problem

Hello China-Dragon,

 

Please, check this link:

http://support.microsoft.com/kb/2938053

 

Most likely, your issue is related to it.

 

Best regards,

Vad