DeepGuard seems to cause problems for PostgreSQL database

Scholar

DeepGuard seems to cause problems for PostgreSQL database

Recently we started seeing problems in PostgreSQL and the logs were full of error messages like the following:

2016-11-14 10:21:45 CET LOG: could not reserve shared memory region (addr=00000000022C0000) for child 000000000000060C: error code 487
2016-11-14 10:21:45 CET LOG: could not fork autovacuum worker process: No error

 

First it seemed like this started happening after recent Windows updates but further investigation has shown that the problems disappear when we disable F-Secure and more specifically the DeepGuard feature. In the DeepGuard settings postgres.exe is on the list of allowed applications.

This is happening on both Windows 10 Pro and Windows 7 SP1 both with the latest Windows updates.

 

F-Secure settings are in our case controlled by our IT department and we would of course like to still have DeepGuard enabled. However, at the same time we need our databases to work.

Are there any logs or similar that contain information on what DeepGuard has blocked? Can you explicitly add an executable beforehand to the list of allowed processes in DeepGuard?

It seems this post talks about the same issue.

 

Best regards,

Mikael Wallen 

 

Tags (1)
1 REPLY 1
Superuser

Re: DeepGuard seems to cause problems for PostgreSQL database

Hello,

 

F-Secure DeepGuard has a baseline mode and an Advanced Process Monitoring mode (which is now the default and uses a mini-DLL injection method that may, rarely, cause incompatibility). If your problem remains even with DeepGuard running in basic mode, then:

 

I think you need to run the built-in F-Secure Support Tool diagnostics on a typically problematic computer and submit the resulting FSDIAG archive to F-Secure Support (via a local partner if necessary) to have the problem sorted out.

 

Best regards: Tamas Feher, 2F 2000, Hungary.