What are the system requirements for Client Security for Mac 13.x?

Thisarticle lists the system requirements for Client Security for Mac 13.

Recommended hardware requirements

  • Intel processor
  • 250 MB of free disk space
  • 1 GB or more of memory
  • An Internet connection is required to validate your subscription and receive updates

Supported operating systems

  • macOS version 10.13 "High Sierra"
  • macOS version 10.12 "Sierra"
  • OS X version 10.11 "El Capitan"

Supported browsers

  • Safari
  • Mozilla Fireforx
  • Google Chrome

Supported versions of F-Secure Policy Manager

  • F-Secure Policy Manager 13.x
Pricing & Product Info

For product info and pricing please go to the F-Secure product page

Version history
Revision #:
4 of 4
Last update:
Wednesday
Updated by:
 
Labels (3)