Software Updater does not patch JRE if JDK gets installed on the same system

Symptoms

F-Secure Software Updater (SWUP) does not patch JRE.

Diagnosis

Even though Java Development Kit (JDK) is listed as a product supported by SWUP, we want to emphasize that SWUP does not patch JRE (32-bit and 64-bit) whenever Java Development Kit (JDK) is installed on the same system.

The reason for this is that, by design, JDK is a scan-only product, and it does not support patching JDK. Nor will it offer updates even for JRE in this instance because applying the JRE update would break the JDK on the system.

Solution

To allow SWUP to patch JRE on a system with JDK installed, you will need to remove JDK manually.

Pricing & Product Info

For product info and pricing please go to the F-Secure product page

Version history
Revision #:
15 of 15
Last update:
‎11-10-2019 06:50 AM
Updated by: