How to set the Policy Manager Server to accept remote Policy Manager Console connections

Issue:

  • Policy Manager Server is rejecting Policy Manager Console connections from a remote host. 
  • When trying to connect to Policy Manager Server running on Linux using a Windows machine, the following error is displayed: "Cannot connect to server 172.16.0.6:8080. Check that the host name and port number are correct. Port number 8080 is used by default".
  • When checking netstat output on a Windows server running the Policy Manager Server, the administration module (default port 8080) is listening on Local address 127.0.0.1

Resolution:

By default F-Secure Policy Manager Server is set up to only accept connections from localhost. Follow the steps below to allow remote connections and then test the connectivity from the remote Policy Manager Console.

If Policy Manager Server is installed on a Windows OS:

  1. Stop F-Secure Policy Manager Server services
  2. Open registry
  3. Go to: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Data Fellows\F-Secure\Management Server 5
  4. Edit the value of [REG_DWORD] RestrictLocalhost to 0
  5. Start F-Secure Policy Manager Server services
If Policy Manager Server is installed on a Linux OS: 
  1. Stop the Policy Manager Server daemon (/etc/init.d/fspms stop)
  2. Open the file /etc/opt/f-secure/fspms/fspms.conf
  3. Check the line adminExtensionLocalhostRestricted value and make sure the value is set to false
  4. Save the file and restart the Policy Manager Server daemon (/etc/init.d/fspms restart)
Once Policy Manager Server service has restarted, try to login from the remote Policy Manager Console.

Please do check our other F-Secure Community KB article as well.

Article no: 000001368

Pricing & Product Info

For product info and pricing please go to the F-Secure product page

Version history
Revision #:
3 of 3
Last update:
‎17-12-2019 06:14 PM
Updated by: