Sense losing internet connection



My sense loses it connection to internet very briefly.

I notice this when online gaming (dota2) as the game suddenly freezes for 1-5secs.

I rebooted sense today to see if it helps, it didnt.

Also got the two diag.logs right after the connection drops.

The Sense device shows No intenert connection on with its lights when this happens.

Tried different dns servers, but didnt make difference.

My sense winpc app is on gaming mode.

OS is win10pro.


My setup:


Latest Sense beta app on android.

Latest version of Sense firmware is installed.

All protections are on, but switching them of didnt make difference.

Fritzbox 6490 cable internet, 250/20 from anvia/elisa/saunalahti.

Sense connected to lan port of the fritzbox which is in bridged mode.

PC is connected via cable to sense's lan port.



  • Opened a case via chat about this and emailed the logs.

  • FS_SimoFS_Simo Posts: 256

    Thanks for reporting this, i'll take a look once I get your logs from customer care.


    Best Regards:

    Simo / SENSE QA Lead

  • JOnesJOnes Posts: 269 Adventurer

    Perhaps a silly question.Can you reproduce the issue without Sense-router  by connecting your pc directly to lan port of you're cable modem.

  • Not a silly question and I was already going to test that out next. 

  • Okay played one match with pc directly connected to WAN router, no issues.

    Will have to play few more games to see the difference, and will then try again with pc connected to sense to see if it happens.

    Edit: Played few more and no issues.

    Will see if I have time today to test it again.

  • After trying again with pc connected to sense, the issue is back.

    There's like some 10-40min "interval" when it happens.

    The Sense again showed the lost internet icon.

    Sent a new log via email to the case.

    I'll try with my laptop also to see if it happens with different devices, but clearly something happens with the sense router.

  • UkkoUkko Posts: 3,021 Superuser

    @FormerMember wrote:

    After trying again with pc connected to sense, the issue is back.

    There's like some 10-40min "interval" when it happens.

    The Sense again showed the lost internet icon.

    Sent a new log via email to the case.

    I'll try with my laptop also to see if it happens with different devices, but clearly something happens with the sense router.



    Sorry for my reply!

    What a nice troubleshoot steps with playing for re-sure that trouble is there or not (much more interesting than re-check some other troubles). :):)

    But just as my potential suggestion:

    Does SENSE router can be "too hot"? And do work more slowly? As result -> such kind of freezes;

    While your another router can be more cool (with all meanings);


    But this is should be only 'potentially' valid - if trouble is back with another devices too;


    Sorry else one time.



  • JOnesJOnes Posts: 269 Adventurer

    Nice issue indeed,with customer tools pretty troublesome to resolve.Do you have a possibility to assign static WAN ip address/netmask/gw/dns to Sense router?.If yes, you could try that.I do not know if there's an option to run sense in debug mode to discover issues like this instead of basic reverse engineering.


  • WAN provider is only providing dynamic ip config.

    Can change dns servers, but they do not have any affect on the issue.

  • JOnesJOnes Posts: 269 Adventurer

    Pity,missed that testing possibility.One option also would be using  nat at the Cable-router level ie. getting sense operate at it's default home-configuration(no bridging) at the Wan-router port.With

    that configuration you can more easily adjust option like dhcp lease times etc which may originally cause the root symptom.Eventually let's hope the sense-developing team could reproduce the issue at the lab-level.

  • Yeah that is one thing I could try.

    I have now tested with my laptop and different cable between pc/laptop-sense.

    The issue occured with laptop after ~20mins.

    Submitted a new log via email again.

    I think I'll next try what you suggested and then factory reseting sense, which I would rather not do but have to try of course.

    I also now switched my pc to different sense lan port to see if that makes any difference.

  • And regarding what Ukko asked: Sense is running cool. My WAN router feels more warm even.
  • When Sense loses Internet connection, try pinging an IP-address on the Internet.


    This is what happened to my device- connection was not actually lost, but DNS resolution did not work.


    2017-09-13 software update seems to have fixed this problem for me.

  • Good idea but I actually did that already, just forgot to mention.

    So I was pinging (google public dns ip) and when the issue happens, the pinging times out for 1-5 pings.

  • FS_SimoFS_Simo Posts: 256

    Hi, I finally got your logs from customer care, sorry about the delay.


    There's a few findings:

    I can see that the link in port4 (WAN) keeps going up and down, which may explain the breakups, the reason for that is unclear though, have you doublechecked that ethernet cable you use in WAN is ok?

    Check if you have another cable and try with that and see if the interface stabilizes.


    [146029.920000] RTL: Link Status Changed - Port4 Link DOWN
    [146032.930000] RTL: Link Status Changed - Port4 Link UP
    [146534.020000] RTL: Link Status Changed - Port4 Link DOWN
    [146537.030000] RTL: Link Status Changed - Port4 Link UP
    [146686.060000] RTL: Link Status Changed - Port4 Link DOWN
    [146688.070000] RTL: Link Status Changed - Port4 Link UP
    [150157.390000] RTL: Link Status Changed - Port4 Link DOWN
    [150159.390000] RTL: Link Status Changed - Port4 Link UP
    [150491.420000] RTL: Link Status Changed - Port4 Link DOWN
    [150494.430000] RTL: Link Status Changed - Port4 Link UP


    I can also see that the daemon responsible for device identification had crashed in both the logs. It should not affect things, but just in case you could turn off "identify my devices" feature from the app and see if that improves your stability at all.  We'll try to figure out if we can find a cause for that device discovery crash and fix it.

  • I'll try those and report back.

  • I brought my ethernet cable tester from work and it gave green lights for the cable between wan and sense router. Anyhow I replaced it with brand new one and even tested that also, green lights.

    Also tested my pc->sense cable, green lights.

    I'll disable the identify my devices feature and test out if the issue is still there.

    Also switched the lan port on my wan router to different one.

  • Oh well the issue was there again.

    Even tried to disable all protection settings from sense, didnt help.

  • LKoLKo Posts: 13

    I also have similar problem.

    DNS issue went away with newest firmware, but I lose Internet constantly.


    My setup is as follows:

    4G Huawei B525 -> <- Ethernet -> <-Generic switch -> <- Ethernet -> <- F-Secure SENSE -> <- 5GHz WLAN -> <- End devices


    When I lose the connection, first I tried to ping Huawei's IP address:

    PING ( 56 data bytes
    Request timeout for icmp_seq 0
    64 bytes from icmp_seq=1 ttl=63 time=308.752 ms
    Request timeout for icmp_seq 2
    Request timeout for icmp_seq 3
    --- ping statistics ---
    5 packets transmitted, 1 packets received, 80.0% packet loss
    round-trip min/avg/max/stddev = 308.752/308.752/308.752/0.000 ms

    Then I tried to ping SENSE's IP address:

    PING ( 56 data bytes
    Request timeout for icmp_seq 0
    Request timeout for icmp_seq 1
    Request timeout for icmp_seq 2
    Request timeout for icmp_seq 3
    Request timeout for icmp_seq 4
    Request timeout for icmp_seq 5
    64 bytes from icmp_seq=6 ttl=64 time=817.418 ms
    Request timeout for icmp_seq 7
    Request timeout for icmp_seq 8
    Request timeout for icmp_seq 9
    Request timeout for icmp_seq 10
    Request timeout for icmp_seq 11
    Request timeout for icmp_seq 12
    64 bytes from icmp_seq=13 ttl=64 time=4.313 ms
    Request timeout for icmp_seq 14
    Request timeout for icmp_seq 15
    64 bytes from icmp_seq=16 ttl=64 time=34.811 ms
    64 bytes from icmp_seq=17 ttl=64 time=15.494 ms
    64 bytes from icmp_seq=18 ttl=64 time=23.781 ms
    Request timeout for icmp_seq 19
    Request timeout for icmp_seq 20
    Request timeout for icmp_seq 21
    64 bytes from icmp_seq=22 ttl=64 time=47.728 ms
    Request timeout for icmp_seq 23
    Request timeout for icmp_seq 24
    64 bytes from icmp_seq=25 ttl=64 time=620.753 ms
    Request timeout for icmp_seq 26
    64 bytes from icmp_seq=27 ttl=64 time=306.122 ms
    64 bytes from icmp_seq=28 ttl=64 time=17.513 ms
    64 bytes from icmp_seq=29 ttl=64 time=2.307 ms
    --- ping statistics ---
    30 packets transmitted, 10 packets received, 66.7% packet loss
    round-trip min/avg/max/stddev = 2.307/189.024/817.418/281.876 ms

    After changing from SENSEs WiFi to Huaweis one:

    PING ( 56 data bytes
    64 bytes from icmp_seq=0 ttl=64 time=1.296 ms
    64 bytes from icmp_seq=1 ttl=64 time=0.999 ms
    64 bytes from icmp_seq=2 ttl=64 time=1.824 ms
    64 bytes from icmp_seq=3 ttl=64 time=1.996 ms
    64 bytes from icmp_seq=4 ttl=64 time=2.128 ms
    64 bytes from icmp_seq=5 ttl=64 time=3.523 ms
    64 bytes from icmp_seq=6 ttl=64 time=1.542 ms
    64 bytes from icmp_seq=7 ttl=64 time=1.232 ms
    64 bytes from icmp_seq=8 ttl=64 time=1.607 ms
    64 bytes from icmp_seq=9 ttl=64 time=2.779 ms
    64 bytes from icmp_seq=10 ttl=64 time=3.178 ms
    64 bytes from icmp_seq=11 ttl=64 time=1.888 ms
    64 bytes from icmp_seq=12 ttl=64 time=1.287 ms
    64 bytes from icmp_seq=13 ttl=64 time=2.097 ms
    64 bytes from icmp_seq=14 ttl=64 time=83.497 ms
    64 bytes from icmp_seq=15 ttl=64 time=73.500 ms
    64 bytes from icmp_seq=16 ttl=64 time=100.274 ms
    64 bytes from icmp_seq=17 ttl=64 time=122.790 ms
    64 bytes from icmp_seq=18 ttl=64 time=3.478 ms
    64 bytes from icmp_seq=19 ttl=64 time=1.511 ms
    64 bytes from icmp_seq=20 ttl=64 time=2.224 ms
    --- ping statistics ---
    21 packets transmitted, 21 packets received, 0.0% packet loss
    round-trip min/avg/max/stddev = 0.999/19.745/122.790/37.416 ms

    So the connection between my laptop and SENSE was already really bad, changing to Huaweis WiFi fixed everything.




  • Okay tried factory reseting sense and left it with bridged mode from wan router, same issue remains.

    Also tried double not as in not in bridged mode, same issue.


    So I am out of ideas now, I cannot use this router if it only keeps internet connection stabile for 20-40mins.

  • JOnesJOnes Posts: 269 Adventurer

    Ask for a replacement in case of a hardware related failure(lan port module etc.)Somewhat similiar issues have been introduced also here at community with Lan-cable connected devices and Sense-router also with disabled security features.Root causes of these have not been identified yet.

  • FS_SimoFS_Simo Posts: 256

    There shouldn't be any reason for the WAN interface to fluctuate, unless the upstream router is dropping it for some reason or the cable is defective, but can assume that has been ruled out.


    @FormerMember Let's try a hardware replacement. Let's also make arrangements to send that unit back to us here in r&d so we can investigate it. You can reference this discussion when you get in touch with support. If this behavior happens also on the new unit, we need to start digging elsewhere for causes.


    Best Regards:

    Simo / SENSE QA Lead

  • I have one more ace in my sleeve to try, before I go for my second Sense replacement. :)

    I have 4g router which I'll plug the sense to see if the issue is somehow related to my cable router, though the issue isn't there when pc is directly connected to the cable router.



  • FS_SimoFS_Simo Posts: 256

    By the way those logs you sent also show that also some LAN ports are also going up and down, I assume you're not actively disconnecting and connecting stuff physically from the router? It can be normal (some devices do that when they go to sleep), but just in case.


    Let us know what happens with the 4G router, thanks for testing!

  • Oh well then there might be issue with sense router since those other lan connections are static.

    Other is NAS and other philips hue bridge which both have constant activity.


    With the 4g router, it worked for the 40mins which i had time to test today.


    @FS_Simo Do you think that the cable wan router even could cause the issue to all wan/lan ports of the sense router as in the up and down?

  • FS_SimoFS_Simo Posts: 256

    I'm not sure, there's a chance it's some kind of an electrical glitch when those are connected in a circuit, but hopefully not.


    If SENSE continues working 'perfectly' with the 4G router, then we could still try to narrow down the problem with the other router.


    You could try one more scenario: reset and update / reconfigure your upstream router and check if there is any improvement to the situation. Does it make a difference if it's not bridging but NATting?


  • Reseted the WAN router, tried Sense without bridge.

    Issue is still there.

  • Now I had the time to test it with the 4g router.

    It worked better with it but the issue was still there.

    Dunno if just luck or what.

    Also I do not know if the issue has been there from the start, since I "returned" to gaming on september and I have had the Sense longer but did not game back then.

    And in internet gaming you notice these kind of issues immideatly and also before the latest router update, you couldn't see the if sense lost internet connection briefly.

    So the issue is pretty easy to reproduce, just play some internet game like dota 2 for 10-120mins and it will show up.

    I notified the customer care about this and submitted the latest log files, and asked for replacement.


    The 4g router is ZTE MF286 with DNA 4G (from my work)

  • FS_SimoFS_Simo Posts: 256

    Thanks for the information, we have been playing some other online games without known major problems. Hopefully it's a hardware issue and gets fixed with a replacement. At least there are no wide-spread reports of this kind of problems yet.


    If it's not a HW issue, further investigation is definitely necessary. Getting your faulty device back to R&D would be appreciated so we can investigate it.

  • Yeah I would assume so, since if there were a lot of issues with gaming you would know. :)


    You will probably get the device there next week if the replacement process goes as planned.

    Do I need to inform the customer care that you want the device to R&D or have you already done that?

This discussion has been closed.