Sense app on iOS lost all devices

Hi Sense Team,


My Sense app has lost all devices!

It says:


- connected (0)

- not connected (0)


However, I can view the status of the Sense router, and change settings, for example, which seems to mean I am definitely connected...?!?


I am running iOS 11.0 Beta 8 (15A5368a), which may have something to do with it...?


Any ideas?






  • FS_SimoFS_Simo Posts: 256 Former F-Secure Employee



    Normally the SENSE app should read the device status from the SENSE router and show it on screen, but for some reason it's not able to get that information or something else is going on.


    There has been some reports of lost devices from the list, we are still investigating the possible issues but it is not yet clear what is happening. If the situation is still ongoing, you could get a diagnostic log from your device (http://sense.router/diag.log) and send it to us via sense-feedback(at) Do not paste it's contents here, it may contain things like your public IP address.


    Please reference this discussion so I'll know it's you.


    Once you have obtained the log, you could try just restarting SENSE and the mobile app and check if the situation is resolves.


    Best Regards:

    Simo / SENSE QA Lead

  • AragonMaverickAragonMaverick Posts: 9 New Member

    Hi Simo,


    I send an e-mail with a diagnostics log to the mail address you provided.

    I also restarted the sense, my iphone and the app, and now the devices are back!




  • Hi,


    I had the same issue today, started yesterday (01. Sept)


    The issue was 1 of 16 devices was stated connected in the app, only my iPhone. But it worked to block units that was offline from internet access. All devices had working wifi, but was "not connected" in Sense app. 


    Reboot of sense router and 2-3 mins later they showed up as connected.

  • FS_SimoFS_Simo Posts: 256 Former F-Secure Employee

    I received the diagnostic log.


    Looking at your logs we have identified that there is an issue related to the device discovery process clearly visible in the logs, but it may take some time for us to figure out how to reproduce it and fix it.


    So the work-around currently is to restart the SENSE router, once we identify the problem it's possible to implement a fix to this issue.


    Thanks for providing this data for us, it is important and really helps us improve the product.


    Best Regards:

    Simo / SENSE QA Lead

  • Would it be an option to add a restart function of the SENSE router from the app? 

  • FS_SimoFS_Simo Posts: 256 Former F-Secure Employee

    Thanks for your input. We will discuss about this feature. Obviously our goal is to build a system that should not require user reboots, but if people find that useful we can consider it.



  • Hi, 

    Yesterday evening, this did happen once more. Only the phone with the SENSE app was connected. And since I did a pretty setup, the power is connected behind the TV, and the router is on a small shelf. 
    (looking into adding a smart power plug to do a reboot for the SENSE)

    After reboot, all devices was displayed online within 4-5 mins. 

  • GuestGuest Posts: 1 New Member



    I'm experiencing the exact same issue mentioned in this thread. After some time, let's say a couple of days, SENSE app on my iPad is unable to list the connected or protected devices. Networking works on all devices, threats are blocked and so on, but none of the devices are listed so for example settings of those cannot be configured.


    After rebooting SENSE router devices appear on the list normally, but the problem persists after some time. I've done numerous reboots over the past weeks and don't bother anymore unless I need to configure something.


    I'm using iOS 10.3.3, latest version of SENSE (AFAIK) and have some 40 devices configured to use SENSE. I can provide logs if that helps resolving this, thanks.

  • FS_SimoFS_Simo Posts: 256 Former F-Secure Employee

    Thanks for the report,

    We have a pretty good understanding why the device list is empty. There's some kind of an issue with the device discovery process on the SENSE router and it is unable to give a response to the app when it is asking for a list of devices, but we are still trying to reproduce the issue. It is not yet obvious how we get there.


    Hopefully we get to the bottom of this soon and can provide a fix.

  • my devicelist is also empty, restarting Sense did not help. I am on iOS 11.


    I guess Sense works like it should, so I won't reset it to factory defaults and instead wait for a fix.

  • I have also the same issue. Upgrade to ios 11 today, and no devices. It does log unwanted urls, but I want the device list back.

  • I would guess that ios 11 is not yet fully supported.

  • AragonMaverickAragonMaverick Posts: 9 New Member

    That might be the case, allthough rebooting both devices and re-pairing them solved the problem for me. I was running the Beta, and now I'm on the GM.

  • I did also a complete restet of Sense, now the devices are back.

    but, of course, my whitelisted sites are gone Smiley Sad

  • Resting a device just due to new OS version is not an option. It should work by default. This doesn't make Sense to me...


    F-Secure-SENSE, any update?

  • haha I like "this doesn't make Sense" Smiley Very Happy


    too late for me, the app also did not work as it should. for example, I disabled the protection in the app, closed it, and it was enabled again.

  • FS_SimoFS_Simo Posts: 256 Former F-Secure Employee



    Apologies for the inconvenience,


    The iOS version shouldn't make a difference in this case (we are also testing with iOS 11). There is some kind of a glitch in the device discovery process in the router and it fails to return the device list to the app. We have enough logs to understand what the situation is, but not yet how to get there (i.e. how to reproduce the issue). Once we can reproduce it we should be able to figure out how to fix it.


    Restarting SENSE _should_ resolve the issue (as long as the phone is back in the SENSE network and establishes communications again). If it doesn't it would be interesting to get another log from that scenario (grab http://sense.router/diag.log and send it to sense-feedback(at), referencing this discussion, but do not paste it here as it may contain things like your public IP address.)


    Thanks for your patience and best regards:

    Simo / SENSE QA Lead

  • Hi @fs_Simo 

    I will send logs and screenshots from the app when I get home today. It worked yesterday before the iOS 11 update, but not after, so something with the update made the device list go "booof away"

    Before, when I had this issue, it listed at least the phone as connected device, not it says 0 on both parts.

    Sending logs in a few hours.

  • Should I reset the router to get it back? Reboot doesn't help. And I cannot i.e. control if a device should have internet access or not...

  • FS_SimoFS_Simo Posts: 256 Former F-Secure Employee

    I took a look at the log,  I can't see anything obvious wrong, except that the clock on SENSE was 2 months in the future when it started and before it had a chance to sync.


    The device visibility and online/offline status in the apps is based on the difference of the 'last seen' timestamp it gets from the gadget and the time and date on your phone. If there's a discrepancy of 5 days, the devices are filtered out of view. The idea was that we would automatically filter out devices that remain offline for a longer period of time.


    This logic appears to be clearly problematic in some scenarios where the device clock is off and we are already having discussion on how to improve it.


    If you can doublecheck that the date/time of your phone  is accurate, then the issue could be on the router side. If rebooting the SENSE router doesn't help (it usually should), you could try a soft-reset of sense (when it's running, 15+ seconds of reset-button and release it), clear the app data and running the setup again.


    Apologies for the inconvenience, but please rest assured that this is now one of our near term fix-list items.


    Best Regards:

    Simo / SENSE QA Lead

  • Hi,


    My mobile get the time from the operator, so it was not the case.


    Tested soft reset two times, but the app lost the connection with the Sense after entering wifi name.


    Ended up with a factory reset... Forgot to take a screenshot of the port forwarding setup...


    At least the device list is up to date.


    BTW, the list doesn't support Norwegian letters, I have a apple TV with the letter Ø in it. Don't show in the list, so might add support for ÆØÅ as well Smiley Wink


    Keep up the good work F-Secure-SENSE team.


  • FS_SimoFS_Simo Posts: 256 Former F-Secure Employee

    Thanks for letting us know,


    Can you please clarify what you mean by the norwegian letters:

    1) "don't show in the list" = our app keyboard is missing norwegian?

    2) "don't show in the list" = it doesn't appear in the devices list on the phone at all because it has a norwegian character in the name?





  • Sure I can.


    My Apple TV name is:

    SMØLA (Place in Norway)


    Device list name in Sense is :



    My iPhone finds it as SMØLA.


    Is it a apple bug or Sense?

  • TugeTuge Posts: 14 Observer

    I have the same problem, i.e. Sense has lost all the devices, that is the device list is completely empty. I noticed this today, so I am nyt sure if this is related to the iOS 11 update on my iPad, or to the update of the Sense App (that was updated yesterday, after the iOS 11 update).


    I have experienced a nearly similar problem before after an update to the Sense App. Not completely sure, but I think that at that time the device list showed my iPad, and rebooting Sense resolved the issue. Now the list is completely empty, and rebooting Sense does not help. I am unwilling to try a reset.


    Also, not sure if related, but all the event logs are also completely empty in the Sense app (the System and Threat listings that is). I am not sure if this is related to the rebooting of the device I did a couple of times, as I only noticed this a few moments ago.

  • FS_SimoFS_Simo Posts: 256 Former F-Secure Employee

    Thanks for these reports, can you try one thing for us:


    Are you able to change the SENSE settings in this state? for instance, try changing the display brightness from hardware settings. If chaning these settings is not working even though the app shows a 'blue' state  then we may have a theory what's going on which allows us to move forward.


    Best regards:

    Simo / SENSE QA Lead

  • I in the „Blue state“ and Sense does not change the brightness to dim or off

  • TugeTuge Posts: 14 Observer



    Yes, this is exactly the case. Changing e.g. brightness setting from iOS app has no effect in the Sense device.

  • same here. sense router has no function at the moment

  • D-Fens2D-Fens2 Posts: 78

    whitelisting of sites doesn't work, too...

  • FS_SimoFS_Simo Posts: 256 Former F-Secure Employee

    Hi, thanks everyone for providing this info and should be leading us to the right tracks.


    We have a likely theory what has happened: Due to a possible bug the iOS client may have overwritten the encryption password (generated during pairing) used for communication between the gadget and the app in some circumstances. Establishing a link between SENSE and the app works (that's why the status is blue) but none of the crucial messages for operating the system can be sent nor received.


    We have made some improvements in the client that should hopefully make sure the password is protected from such behavior. The unfortunate bad news is that the only way to recover from this is a system reset and re-install. Also until the fixed client is available, the issue may re-occur for the affected users.


    There's still some polishing and testing going on with the iOS client but we hope to make it available soon. I will inform everyone here when the build with a fix is on its way out.


    We sincerely apologize for the inconvenience and thank you for your input.

This discussion has been closed.