Announcement: New Knowledge Base

4 June 2020: We are pleased to announce the launch of a new Knowledge Base, Changelogs for Business Security Products, where you can find more details, such as bugfixes or new features, about the most recent releases of our business-related products.

PMS server Java 100% after several days.

I have weird problem.

I have a policy manager running on a Windows 2012 R2 (last updates from februari.)

Running the latest Policy manager.

Updated Java to the last version.

 

But after several days the Java.exe is going up to 100%.

If i restart the PMS services the cpu load goes back to normal.

 

This happend also before updating the java version and older version of PMS.

Sometimes it takes 2 or 3 days before this happends, Sometimes it takes 2 weeks....

Any idea what this is causing?

 

Comments

  • BenBen Posts: 2,640

    Hello Gaasbeek,

     

    Could you tell us how many hosts are managed by this PMS? 

    Also what is the hardware on this server?

  • BenBen Posts: 2,640

    Hello Gaasbeek,

     

    Could you tell us how many hosts are managed by this PMS? 

    Also what is the hardware on this server?

  • GaasbeekGaasbeek Posts: 17
    800+- Clients and 80 servers are managed bij the PMS.

    Server is running within VMware.
    HW version 9 (current with the esx version running @ this moment)
    Latest VMware tools installed.
    1 CPU 2GB mem (enough for when it is operating normaly)

    When it is running smooth then it uses 1.2/1.3GB and load on cpu between 5 and 20%.
  • ButaButa Posts: 12

    Hello Gaasbeek,

     

    How much memory do you have allocated for JVM?

    If you use default setting (which is 512M) try to increase it up to 1024M in registry

    (java_args=-Xms64M -Xmx1024M)

  • GaasbeekGaasbeek Posts: 17

    I have changed the max mem as listed above.

    But same result now.

    Server used 100% cpu starting Monday (16:00) and didnt calm down again.

     

  • PeterPeter Posts: 186

    Hi,

     

    Having a high amount of hosts connect to the server using default FSMA polling intervalls (10 minutes) is also known to cause a similar issue.  Check your polling intervals. The setting in PMC is here:

     

    f-secure management agen

       settings

          communications

                  protocols

                      http

                           incoming packages polling interval

                           outgoing packages polling interval

     

    Try increasing the value from default 10 minutes to say 30 minutes or 1 hour. If the issue persists, consider submitting a support ticket, so we can have a closer look at the relevant PM log files.

     

     

     

     

This discussion has been closed.