Unable to connect devices - pc to ipad using key premium

I am using windows 8 and I upgraded a while ago to key premium on my PC, which it is saying it is. When I try to connect devices my PC just states if you have KEY PREMIUM generate a code on another device and enter it here. On my ipad it states the same thing. My ipad shows in yellow key free subscribe now but when I go into subscriptions it just gives me payment options. If I go into help and enter voucher and enter the premium voucher code it states validation failed - could not validate the voucher. This code has already been used or has expired. I have tried uninstalling the app and adding again but still have the same problem so I feel like I am going round in circles. I am using iOS 8.4.1 software on my ipad.

Best Answer

  • LakshLaksh Posts: 4,426
    Accepted Answer

    Hi debs1,

     

    I will contact you via Private Message for further discussion.

Answers

  • LakshLaksh Posts: 4,426

    Hi debs1,

     

    Could you please try the steps give here to sync your devices with your Windows 8?

  • As advised on my initial post I cannot generate a code as it just tells me when I click on connect devices  'If you have KEY PREMIUM generate a code on another device and enter it here'. It's therefore not letting me generate a code at all.

  • dukavidukavi Posts: 107

    You should have at least one device with Premium subscription enabled. On this device you may generate sync code and then enter it to other device to enable sync. Vouchers are of one time use, if you e.g. removed software completely and then installed again, you will lose your Premium subscription and old voucher can’t be used any more. If you have this kind of problem, I am sure F-Secure support will help you to solve it.

  • I already have premium subscription as previously stated on my laptop but I still can't generate a sync code. I contacted support and they advised me that I needed to come on here to get help. This is getting pretty frustrating now as no-one appears to want to help me resolve this.

This discussion has been closed.