E-mail and server security upgraded - Exchange scanning no longer works

stmartistmarti Posts: 29 New Member

I have an SBS 2011 with a working email and server security version 9.x

Recently I upgraded it to version 11.01. Seems it was a stupid idea...

 

Since then the Exchange scanninig, outbound rules, anything related to Exchange not works. Looks like the Exchange component not installed/works at all.

 

My policy manager is the latest (11.22)

I have checked the Policy in advanced mode for this server:

- Installation tab: Installed product summary: F-secure E-Mail and Server Security 11.01 - OK

- Policy tab:

  • "F-Secure E-Mail and Server Security 11.01" is bold - OK
  • "F-Secure Anti-Virus for Microsoft Exchange" not bold - NOT OK

How to fix this? At the moment we are not protected at all in Exchange.

 

Accepted Answer

Comments

  • VadVad Posts: 1,068 F-Secure Employee

    Hello stmarti,

     

    What was your upgrade scenario?

    I would propose you to reinstall the product locally (using ESS 11.01 exe installer).

    If this will not help, please try to uninstall, clean registry manually, and install the product again.

    Please, contact support for details, if needed.

     

    Best regards,

    Vad

  • stmartistmarti Posts: 29 New Member

    I try to export the jar to msi in the policy manager, to make a standalone re-install on the server.

     

    However during the msi export in the Selct components to install I see this:

    - Anti virus for Microsoft Exchage (only update)

     

    What "only update" means?

  • stmartistmarti Posts: 29 New Member

    I try the standalone installer, but it fails, cannot create the quarantine database.

     

    I have sql server 2012, the installer connects to the sql server but I get:

     

    The setup program failed to create the quarantine database.

    Error. Directory lookup for the file:

    "....\FSMSE_Quarantine.mdf" failed with the operating system error 2 (The system cannot find the file specified)

     

    (EDIT: The sql server default database location pointed to an non existing path.)

  • VadVad Posts: 1,068 F-Secure Employee

    As far as i remember there is a possibility to use existing quarantine DB, or to create a new one.

    Did you try both? If installation fails in both cases, please, contact support.

     

    Best regards,

    Vad

  • stmartistmarti Posts: 29 New Member

    The fix was:

    - uninstall all f-secure component

    - install with the standalone exe installer

    - delete server from the policy manager

    - import the server (from the new hosts) in the policy manager

     

    What not worked:

    - We used 9.x Antivirus for Exchange

    - Upgrade offered to ESS 11 in the policy manager (why if this scenario not supported?!)

    - Started upgrade

    - Upgrade was sucessfull

    - Exchange e-mail delivery completly stopped, all message garbaged by F-secure.

    Chrissy
This discussion has been closed.