How to change HttpPortNum (host module) from 80 to 81 post install

Need to change HttpPortNum (host module) from 80 to 81 after install. What needs to be done to get the clients communicate with the server again? Port 81 is configured to the server registry as guided: http://www.f-secure.com/en_EMEA/downloads/documentation/online-help/pm/900/troubleshooting/concepts/fsmps_fspmc_troubleshooting.html

 

PM 10, FSCS 9.20, 2008 R2, XP.

Comments

  • MJ-perCompMJ-perComp Posts: 1,098 Superuser

    Nothing else needs to be done. The clients will try to find the PMS every hour (default).

     

    Did you use the same ADMIN-Keys? if not they will still not accept the policy!

     

     

  • This is not working, the clients can't connect to PMS. Firewalls off.

  • MJ-perCompMJ-perComp Posts: 1,098 Superuser

    Can you connect using a browser with http-proxy off?

     

    What do the clients think which port is in use?

     

  • Client can connect with browser to port 81. Even installation through Autodiscover works. But hosts last connection to PSM is out of date as is with policy, "not latest". This after changing default port 80 to 81.

  • MJ-perCompMJ-perComp Posts: 1,098 Superuser

    Hi,

     

    stay away from the server console at the moment!

    All we need to know happens on the Client.

     

    Restart the client wait about 3 Mins, then send post the last entries from logfile.log that were created after the startup.

     

    BR

     

  • SYSTEM  F-Secure Management Agent  1.3.6.1.4.1.2213.11.1.14

    F-Secure Management Agent was not able to connect to the server and is now operating in Offline Mode.

    (error number 0: HTTP 404: file not found.)

  • MJ-perCompMJ-perComp Posts: 1,098 Superuser

    Please execute from CMD:

    CD %f-secure%\common

    polutil g 1.3.6.1.4.1.2213.11.1.14.4.2.1

     

    and post the output here.

     

  • Output is the ip of the Policy Manager Server. Nothing else.

     

    http://192.....

  • MJ-perCompMJ-perComp Posts: 1,098 Superuser

    Hi,

    this is what I expected. The client does not know that you changed the port from 80 to 81.

     

    You have to provide the client a policy that has the new PMS-address with port (xxx.xxx.xxx.xxx:<port>) as the communication address AND that setting must be final so that it will override the setting that is set in the client.

     

    "Final" you get either from advanced view or by clicking the lock behind the setting.

     

    Brining that mended policy to the clients is mor difficult, as the client do not fetch the policy any more.

     

    Option 1: go back to Port 80 on the PMS, distribute the policy and wait for each client to fetch it, then change to port 81

    Option 2: export a policy for effected clients and import it there.

     

    If the old policy (with port 80) already has "final" then you better use option 1.

    If you can change the address from the clents GUI, final is not set and you could change the value on all clients using the admin-key-replacer (only available via a support request).

     

    I'd go for Option 1

    HTH

     

     

    jackma
  • daempiidaempii Posts: 25

    Should the firewall needs to be turned off to chage the HttpPortNum? What should be the default? image

This discussion has been closed.