Instalation Linux Client error!

I need help, I have already installed and redid all the procedures of Pr-einstallation checklist link below and I can not finish installing the agent on the linux server.

 

http://community.f-secure.com/t5/End-point/Pre-installation-checklist-for-F/ta-p/44451

 

 

return Complie-Drivers:

 

Running /opt/f-secure/fsav/bin/fsav-compile-drivers Compiling dazuko driver for kernel version 2.6.32-358.el6.x86_64 Driver for kernel version 2.6.32-358.el6.x86_64 - OK. Compiling redirfs driver for kernel version 2.6.32-358.el6.x86_64 redirfs make redirfs; failed. See output in /tmp/redirfs.NIZQhW/make.output Compiling dazuko driver for kernel version 2.6.32-431.20.5.el6.x86_64 Driver for kernel version 2.6.32-431.20.5.el6.x86_64 - OK. Compiling redirfs driver for kernel version 2.6.32-431.20.5.el6.x86_64 Driver for kernel version 2.6.32-431.20.5.el6.x86_64 - OK. Feature summary: - Real-time virus protection enabled - Integrity checking enabled - Firewall enabled Installation completed successfully. Starting F-Secure Linux Security modules (/etc/init.d/fsma start) To configure the product, please run /opt/f-secure/fsav/fsav-config. If you want to completely disable some of the product modules, please run /opt/f-secure/fsav/sbin/fschooser.

 

[[email protected] fsdiag.17200]# cat /tmp/redirfs.NIZQhW/make.output

make: *** /lib/modules/2.6.32-358.el6.x86_64/build/: No such file or directory. Stop.

 

Linux CentOS 6.5

 

Thanks

 

Marlon Piassa

Best Answer

  • FedericoFederico Posts: 38
    Accepted Answer

    Hi,

     

    If you mean you renamed the files, you shouldn't. Please do not rename the files. The files are meant to change and rpm mentioning it can't find them is safe to ignore.

     

    I don't believe zabbix could be preventing the program from writing to that folder, zabbix is supposed to be used for monitoring.

     

    Since the error message suggests the issue could be due to AppArmor, it might be worth looking to see if disabling it temporarily, allows for the files to be written. That being said, those are man pages for fsav, fsavd and dbupdate. They won't affect the program's functions.

     

    Regards,

Answers

  • FedericoFederico Posts: 38

    Hi Marlon,

     

    The logs mention the problem is caused because of the following missing folder:

     

    /lib/modules/2.6.32-358.el6.x86_64/build/

     

    Which is not really a folder but a link to the kernel sources. Either the link is broken or you do not have the kernel sources installed. If the kernel source for that particular kernel is still available in the repositories, you should install it by running a line such as the one below:

     

    yum install kernel-devel-2.6.32-358.el6.x86_64

     

    If the package is not available, you will need to upgrade your current kernel to a version for which you can find its matching devel package.

     

    The installation should work at that point.

     

    Regards,

  • PiassaPiassa Posts: 26

    Hello Federico,

    follows the result of the process,

    redid the whole installation validei all requested in the pre-installation document libraries, ran the command you sent, but the error persists.

     

    [[email protected] ~]# /opt/f-secure/fsav/bin/fsav-compile-drivers

     

    Compiling dazuko driver for kernel version 2.6.32-358.el6.x86_64

    Driver for kernel version 2.6.32-358.el6.x86_64 - OK.

    Compiling redirfs driver for kernel version 2.6.32-358.el6.x86_64

    redirfs make redirfs; failed. See output in /tmp/redirfs.34wQgE/make.output

    Compiling dazuko driver for kernel version 2.6.32-431.20.5.el6.x86_64

    Driver for kernel version 2.6.32-431.20.5.el6.x86_64 - OK.

    Compiling redirfs driver for kernel version 2.6.32-431.20.5.el6.x86_64

    redirfs make redirfs; failed. See output in /tmp/redirfs.p5DOIQ/make.output

    Compiling dazuko driver for kernel version 2.6.32-431.23.3.el6.x86_64

    Driver for kernel version 2.6.32-431.23.3.el6.x86_64 - OK.

    Compiling redirfs driver for kernel version 2.6.32-431.23.3.el6.x86_64

    Driver for kernel version 2.6.32-431.23.3.el6.x86_64 - OK.

     

    Starting real-time protection...done

     

    [[email protected] ~]# cat /tmp/redirfs.34wQgE/make.output

    make: *** /lib/modules/2.6.32-358.el6.x86_64/build/: Arquivo ou diretório não  encontrado. Pare.

    [[email protected] ~]# cat /tmp/redirfs.p5DOIQ/make.output

    make: *** /lib/modules/2.6.32-431.20.5.el6.x86_64/build/: Arquivo ou diretório  não encontrado. Pare.

     

    [[email protected] ~]# yum install kernel-devel-2.6.32-358.el6.x86_64

    Loaded plugins: fastestmirror

    Loading mirror speeds from cached hostfile

    * base: mirror.gtdinternet.com

    * extras: mirror.gtdinternet.com

    * updates: mirrors.dcarsat.com.ar

    Setting up Install Process

    No package kernel-devel-2.6.32-358.el6.x86_64 available.

    Error: Nothing to do

     

    [[email protected] ~]# uname -a

    Linux ftp2 2.6.32-431.23.3.el6.x86_64 #1 SMP Thu Jul 31 17:20:51 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

     

    [[email protected] ~]# cat /etc/issue

    CentOS release 6.5 (Final)

    Kernel \r on an \m

     

    Thanks!

     

    Best Regards,

    Marlon Piassa

  • FedericoFederico Posts: 38

    Hi Marlon,

     

    The instructions were written following the kernel version you were using when you placed the post. Since you are now using a newer kernel, you have to install the corresponding matching packages:

     

    yum install "kernel-devel-$(uname -r)" "kernel-headers-$(uname -r)"

     

    Once they are installed, you can run the installation again.

     

    Regards,

  • PiassaPiassa Posts: 26

    Hi Federico,

    I do not know what to do, already rebooked the procedure several times, already reinstalled the solution in the way that you put in the forum but does not work.

     

    the procedures below is after doing that suggested in other posts.

     

    Installation completed successfully.
    Starting F-Secure Linux Security modules (/etc/init.d/fsma start)

    To configure the product, please run /opt/f-secure/fsav/fsav-config.

    If you want to completely disable some of the product modules, please run /opt/f-secure/fsav/sbin/fschooser.
    [[email protected] f-secure-linux-security-10.00.60]# cat /tmp/redirfs.LpR/make.output
    make: *** /lib/modules/2.6.32-358.el6.x86_64/build/: No such file or directory. Stop.
    [[email protected] f-secure-linux-security-10.00.60]# rpm -qa | grep kernel
    dracut-kernel-004-336.el6_5.2.noarch
    kernel-devel-2.6.32-431.23.3.el6.x86_64
    kernel-firmware-2.6.32-431.23.3.el6.noarch
    kernel-devel-2.6.32-431.20.5.el6.x86_64
    kernel-2.6.32-358.el6.x86_64
    kernel-2.6.32-431.20.5.el6.x86_64
    kernel-headers-2.6.32-431.23.3.el6.x86_64
    kernel-2.6.32-431.23.3.el6.x86_64
    [[email protected] f-secure-linux-security-10.00.60]# yum install "kernel-devel-$(uname-r)" "kernel-headers-$(uname -r)"
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
     * base: mirrors.dcarsat.com.ar
     * extras: mirrors.dcarsat.com.ar
     * updates: mirrors.dcarsat.com.ar
    Setting up Install Process
    Package kernel-devel-2.6.32-431.23.3.el6.x86_64 already installed and latest version
    Package kernel-headers-2.6.32-431.23.3.el6.x86_64 already installed and latest version
    Nothing to do
    [[email protected] f-secure-linux-security-10.00.60]# /opt/f-secure/fsav/bin/fsav-compile-drivers

    Existing dazuko driver for kernel 2.6.32-358.el6.x86_64 is still valid, not recompiling
    Compiling redirfs driver for kernel version 2.6.32-358.el6.x86_64
    redirfs make redirfs;  failed. See output in /tmp/redirfs.sqDHzr/make.output
    Existing dazuko driver for kernel 2.6.32-431.20.5.el6.x86_64 is still valid, not recompiling
    Compiling redirfs driver for kernel version 2.6.32-431.20.5.el6.x86_64
    Driver for kernel version 2.6.32-431.20.5.el6.x86_64 - OK.
    Existing dazuko driver for kernel 2.6.32-431.23.3.el6.x86_64 is still valid, not recompiling
    Compiling redirfs driver for kernel version 2.6.32-431.23.3.el6.x86_64
    Driver for kernel version 2.6.32-431.23.3.el6.x86_64 - OK.


    [[email protected] f-secure-linux-security-10.00.60]# cat /tmp/redirfs.sqDHzr/make.output
    make: *** /lib/modules/2.6.32-358.el6.x86_64/build/: Arquivo ou diretório não encontrado.  Pare.
    [[email protected] f-secure-linux-security-10.00.60]#

     

    best regards

     

    Marlon Piassa

  • FedericoFederico Posts: 38

    Hi Marlon,

     

    As you can see in the logs, the modules are compiling correctly for the kernel you are currently using, 2.6.32-431.20.5.el6.x86_64 (since you followed the steps I mentioned). The issue remains for the old kernel 2.6.32-358.el6.x86_64.

     

    At this point, the program will work correctly as long as you boot on the current kernel. Should you wish to allow the modules to compile for the old kernel, you will need to install the headers and sources for the old kernel too. However, if they are old, you might not be able to find them on the repositories.

     

    That being the case, sticking to kernel 2.6.32-431.20.5.el6.x86_64 will keep the program working correctly. Unless you are really using it, you could remove kernel 2.6.32-358.el6.x86_64. You will then no longer see the compilation error for that kernel version.

     

    Regards,

  • PiassaPiassa Posts: 26

    Excellent Federico

    Actually the error was referring to an outdated kernel. but falls into a similar process with another question I have.

    I installed all the libraries as described in the procedure, ask if the installation it will say is that with the latest version, but in the fsdiag log it shows me that has a lot of missing libraries and I can not install them.

     

     

     

    [[email protected] fsdiag.4975]# cat rpm_verify.txt
    f-secure-automatic-update-agent
    .....UG..    /opt/f-secure/fsaua/bin/fsaua-ctrl

    f-secure-security-platform
    .......T.    /etc/opt/f-secure/fssp/fssp.conf
    ....L....    /opt/f-secure/fssp/lib/libfsmgmt.2.so
      /var/opt/f-secure/fssp/databases/aqualnx32.0 faltando
      /var/opt/f-secure/fssp/databases/aqualnx32.0/libaqua32.so faltando
      /var/opt/f-secure/fssp/databases/fmlibunix.0 faltando
      /var/opt/f-secure/fssp/databases/fmlibunix.0/libfm-lnx32.so faltando
      /var/opt/f-secure/fssp/databases/hydralinux.0 faltando
      /var/opt/f-secure/fssp/databases/hydralinux.0/[email protected]ra.pub faltando
      /var/opt/f-secure/fssp/databases/hydralinux.0/[email protected] faltando
      /var/opt/f-secure/fssp/databases/hydralinux.0/[email protected] faltando
      /var/opt/f-secure/fssp/databases/hydralinux.0/BW_datapak.bif faltando
      /var/opt/f-secure/fssp/databases/hydralinux.0/BW_datapak.bis faltando
      /var/opt/f-secure/fssp/databases/hydralinux.0/[email protected] faltando
      /var/opt/f-secure/fssp/databases/hydralinux.0/bw_name.html faltando
      /var/opt/f-secure/fssp/databases/hydralinux.0/enginefiles-fselinux.set faltando
      /var/opt/f-secure/fssp/databases/hydralinux.0/fsedb.dat faltando
      /var/opt/f-secure/fssp/databases/hydralinux.0/fselinux.cr faltando
      /var/opt/f-secure/fssp/databases/hydralinux.0/hydralinux-update.ini faltando
      /var/opt/f-secure/fssp/databases/hydralinux.0/hydralinux-update.mf faltando
      /var/opt/f-secure/fssp/databases/hydralinux.0/info.iad faltando
      /var/opt/f-secure/fssp/databases/hydralinux.0/libfsecr32-linux.so faltando
      /var/opt/f-secure/fssp/databases/hydralinux.0/licenses-fselinux.txt faltando

    f-secure-management-agent-unix-4.77.1333-1.i386.rpm
    o pacote f-secure-management-agent-unix-4.77.1333-1.i386.rpm não está instalado

  • FedericoFederico Posts: 38

    Hi Marlon,

     

    Those files are part of the Virus Definition database, as they get updated, their name changes. If you go to that folder you will see a few folders which start with the same name but have a different number after the '.' (dot).

     

    rpm won't be able to find the original files because they are no longer there since the database has received updates.

     

    Regards.

  • PiassaPiassa Posts: 26

    Sorry Federico, but I did not.

  • FedericoFederico Posts: 38

    What do you see listed under:

     

    /var/opt/f-secure/fssp/databases/

     

    Regards,

  • PiassaPiassa Posts: 26

    Hi Federico,

     

    cd /var/opt/f-secure/fssp/databases/

    aqualnx32.1407399202  dbupdate_signaling.lock  fmlibunix.1406711097   orsplnx32.0
    db.lock               dynamic-license          hydralinux.1407316850


     

    thanks!

  • FedericoFederico Posts: 38

    Hi,

     

    Those are the folders I mentioned. rpm can't find the original folders:

     

    /var/opt/f-secure/fssp/databases/aqualnx32.0/
    /var/opt/f-secure/fssp/databases/fmlibunix.0/
    /var/opt/f-secure/fssp/databases/hydralinux.0/

     

    Because they were removed an replaced with the ones below as the updates were downloaded:

     

    /var/opt/f-secure/fssp/databases/aqualnx32.1407399202/

    /var/opt/f-secure/fssp/databases/fmlibunix.1406711097/

    /var/opt/f-secure/fssp/databases/hydralinux.1407316850/

     

    Regards,

  • PiassaPiassa Posts: 26

    Hi Federico

     

    I renomiei files and the return was:

     

    .......T.   /etc/opt/f-secure/fssp/fssp.conf

    ....L....   /opt/f-secure/fssp/lib/libfsmgmt.2.so

    .M.......   /var/opt/f-secure/fssp/databases/aqualnx32.0

    .M...U...   /var/opt/f-secure/fssp/databases/aqualnx32.0/libaqua32.so

    .M.......   /var/opt/f-secure/fssp/databases/fmlibunix.0

    .M...U...   /var/opt/f-secure/fssp/databases/fmlibunix.0/libfm-lnx32.so

    .M.......   /var/opt/f-secure/fssp/databases/hydralinux.0

    /var/opt/f-secure/fssp/databases/hydralinux.0/[email protected] faltando

    /var/opt/f-secure/fssp/databases/hydralinux.0/[email protected] faltando

    /var/opt/f-secure/fssp/databases/hydralinux.0/[email protected] faltando

    .M...U...   /var/opt/f-secure/fssp/databases/hydralinux.0/BW_datapak.bif

    .M...U...   /var/opt/f-secure/fssp/databases/hydralinux.0/BW_datapak.bis

    .M...U...   /var/opt/f-secure/fssp/databases/hydralinux.0/[email protected]

    .M...U...   /var/opt/f-secure/fssp/databases/hydralinux.0/bw_name.html

    .M...U...   /var/opt/f-secure/fssp/databases/hydralinux.0/enginefiles-fselinux.set

    .M...U...   /var/opt/f-secure/fssp/databases/hydralinux.0/fsedb.dat

    .M...U...   /var/opt/f-secure/fssp/databases/hydralinux.0/fselinux.cr

    .M...U...   /var/opt/f-secure/fssp/databases/hydralinux.0/hydralinux-update.ini

    .M...U...   /var/opt/f-secure/fssp/databases/hydralinux.0/hydralinux-update.mf

    .M...U...   /var/opt/f-secure/fssp/databases/hydralinux.0/info.iad

    .M...U...   /var/opt/f-secure/fssp/databases/hydralinux.0/libfsecr32-linux.so

    .M...U...   /var/opt/f-secure/fssp/databases/hydralinux.0/licenses-fselinux.txt


    I realized that it generates the following line when I run the setup command
    / opt / FSecure / FSAV / FSAV-config

     

    Configuring...Can't access man pages under /opt/f-secure/fssp/man. Perhaps AppArmor or similar is blocking the access. Please see the distribution's documentation on how to configure it.

     

    apparently use zabbix on the network, has a feature that may be conflicting or blocking? because this is the same error that happens on all servers, including different distributions, CentOS, Debian.

     

    best regards,

     

    Marlon Piassa

This discussion has been closed.