F-Secure blocking games and applications

Heya ! I'm new as using F-Secure and im kinda of confused. It seems like F-Secure is blocking pretty many things on my computer, like some of the games and applications, as i turned F-Secures firewall off, and turned windows own firewall on and they worked just well. And i don't have any idea how to make them work with F-Secure hah. I've tried to make umm.. are they called rules, from the application managment. By that i mean going to application managment and ''allow'' or ''deny'' outgoing and ingoing connections. ps. I'm really sorry if you didn't get what i meant, as english ain't my primary language XDSmiley Happy

Comments

  • ZiPPuZiPPu Posts: 4

     

  • SimonSimon Posts: 2,600 Superuser

    Hello, and welcome to the forum!  Smiley Happy

     

    Firstly, F-Secure doesn't have it's own firewall.  It uses Windows Firewall, so, if applications are working through Windows Firewall, if I understand you correctly, then this doesn't indicate a Firewall issue.

     

    What might be the problem is DeepGuard, which is F-Secure's applications monitor.  When you say you've, " tried to make umm.. are they called rules, from the application managment. By that i mean going to application managment and ''allow'' or ''deny'' outgoing and ingoing connections" - is this in F-Secure's DeepGuard settings, or in Windows Firewall?

     

    Did you get any pop up alerts when things seem to be getting blocked?

     

    Have you tried Gaming Mode, which can be selected by right clicking the FS icon by the clock?

  • ZiPPuZiPPu Posts: 4

    Humm.. really? Smiley Surprised By opening F-Secure - Settings - Internet Access - Firewall, you can disable firewall, which makes everything work just well. So it must mean that the issue is that firewall, right?

     

    And by making these rules i meant from F-Secure - Settings - Internet Access - Application management. I've also tried disabling DeepGuard, and it didn't have any effect, which means in my head that DeepGuard ain't the issue.

     

    I get pop ups only when i open application and it asks if i want to allow internet connection for it etc..

     

    I have no option for Gaming Mode.

  • SimonSimon Posts: 2,600 Superuser
    Which version of F-Secure are you using, ie, 2012, 2013, 2014?

    The settings you described suggest you're not using the latest version, in which case, I would recommend upgrading. Assuming we're talking about a standard retail version, not SAFE, or a version from a third party vendor, you can download the latest installers from here:

    http://www.f-secure.com/en/web/home_gb/support/installers
  • ZiPPuZiPPu Posts: 4

    F-Secure Client Security 11.50 build 309

  • SimonSimon Posts: 2,600 Superuser
    OK. You've posted in the Home Security section, hence the confusion, as I believe FSCS is different to F-Secure Internet Security. The correct section for FSCS is here:

    http://community.f-secure.com/t5/Business/ct-p/Business_Security_Solutions/interaction-style/forum

    Could a moderator please move this thread to the relevant board? Thanks. :)
  • ChrissyChrissy Posts: 439

     @ZiPPu @Simon 

     

    Hi!  Just noticed that this thread should have been moved to the Business Security board, as Simon indicated, so now it's moved!

     

    ZiPPu, any update in the troubles, or do you still need our help?

     

    // Chrissy

  • FedericoFederico Posts: 38

    Hi ZiPPu,

     

    Client Security is focused on corporate environments. Normally you will need to contact your IT administrator in order to add new firewall rules from the Policy Manager Console.

     

    If your IT administrator (or if you are the IT administrator) does allow you to make changes to the firewall rules locally from the client you can do so as long as you know which ports are required by your application.

     

    It is common to allow all outbound connections (not sure how your IT admin has setup the rules in your case), so you will only need to create rules for inbound connections. If you know the ports your application is using, you can simply create a rule to allow that.

     

    Regards,

  • PekkoPekko Posts: 40

    Hi ZiPPu,

     

    Maybe you can follow the instructions on these links about creating firewal rules and how to open ports. 

     

    http://community.f-secure.com/t5/Security-for-PC/How-do-I-add-a-new-firewall-rule/ta-p/16874

    http://community.f-secure.com/t5/Security-for-PC/How-do-I-open-a-firewall-port/ta-p/16870

     

    Some general information and concepts on this link: http://community.f-secure.com/t5/Security-for-PC/Information-about-firewall/ta-p/18272

  • ChrissyChrissy Posts: 439

    Hi ZiPPu!

     

    Any progress on this issue?  Please share! :)

This discussion has been closed.