Missing logon window

Sometime when starting F-Secure KEY (vers. 1.5.145) I don't get any logon window!!

And then I cannot get my passwords!!!!!!

I'm running on a Windows 7 Home Premium with all uppdates.

If I power off my PC and try later on, it may work, but I don't like to not be sure I have access to my passwords!!!!

Please help!!!!!!!!!!!

Accepted Answer


  • UkkoUkko Posts: 3,206 Superuser



    You able to get new one version, which already available -> http://www.f-secure.com/en/web/home_global/key

    It's with new interface, some features.. and maybe... partly fixed for that trouble (with window). And potentially will be "full"-fixed in next releases.


    If you don't want do that (but I recommend do that) - you able to "turn off" autorun-setting (msconfig by "Run" or Task Manager->Autorun  -> and turn off fskey); After that you should be able to launch F-Secure Key manually.... without troubles.



    Of course, if you mean something like that (and current situation not related with something new):




  • PattPatt Posts: 9
    Hi, I can't download the new version on my iPad, but I can on my Mac.
  • Timo_VTimo_V Posts: 38 Former F-Secure Employee

    Hi Patt,


    Do you mean that you can't see the new version in AppStore or that it fails to install? The latest iPad/iPhone version is 1.6.137.




  • olmiolmi Posts: 4

    I too have the same problem, for several weeks now and with different versions of Key. I have a desktop pc with Windows 8.1 64-bit os. Currently my Key version is 1.6140 and the problem continues to exist. I have also tried to disable the autorun for Key and to start it after all other processes have started, but without any success.

  • UkkoUkko Posts: 3,206 Superuser



    Does you mean... that it certainly current trouble?! It also happened just time to time or already regular situation with Key?


    And you disable autorun of Key and just during launch by desktop-picture-shortcut it anyway with trouble-start ?!


    And trouble.. here that "Window without any pictures, but with backgrounds"? What if wait more time after load system and manually launch Key - same situation?


    Also here previously asked about HDD or SSD in use.

    Also I can to ask - do you have any protection-software?


    Sorry for questions.

  • olmiolmi Posts: 4

    It is a regular situation with several latest versions of Key. I disabled autorun from Task Manager. I've waited plenty for system to start but no help there. I have a HDD. My protection software is Windows Defender.

  • UkkoUkko Posts: 3,206 Superuser

    OK....  How I can to understand (because my systems not meet that situation yet) - it was usually "time to time".

    Your situation - each time...


    Maybe here already something new... but anyway....current words can be with meaning - you totally can not to launch F-Secure Key?!

    Or steps with "killing process"/else one launch - help with your situation?


    If you have backup-copy for your passwords -> did you already re-install for F-Secure Key?!


    Here I mean - uninstall F-Secure Key, uninstall F-Secure Key User Data; Restart system.

    Install it again.


    /You able to save your "localstorage" (from user-folder - appdata/local and F-Secure folders) and trying to do that - if without experience with totally clean installation and if you not able to launch Key with any steps./


    Anyway.... here can be potentially troubles with something else around system?! Like if maybe need to checking system for any "unwanted" applications, when Windows Defender can be tricked.


    Sorry for suggestions. Maybe here need else someone with same trouble for understanding - if here have something "global".

    And maybe F-Secure Key Team ready to check your situation with background as "potentially improving prevent-points for current trouble", which was added to latest versions.

  • olmiolmi Posts: 4

    Key starts alright, I mean the process does. With version 1.4something I managed to fix the problem by re-installing Key and restarting my pc. With version 1.5something onwards it didn't help anymore. Killing the process and launching Key again hasn't worked with me. 


    I also deleted the F-Secure folder from my userdata after uninstalling Key and did a clean install, but with no help.


    I have tried to find anything that would cause the problem on my system, but without any luck. I've uninstalled several applications trying to find the reason why Key isn't working as it should. The only strange thing I could find is that my Adobe Flash CS5 stopped working at the same time as Key (It freezes on starting a new project).


    I'm also using Key on my laptop pc, which has Windows 8.1 64-bit os and without any problems. I'm also using it on several mobile devices. No problems there, either.

  • UkkoUkko Posts: 3,206 Superuser

    Thanks for reply.. Probably when F-Secure Key team comes to this topic... they can to check it more...


    My new words.. can be just.. if here something goes to crash about Key UI (some kind of Qt-platform crash). Not sure, but maybe Windows logs/journals have something with that or related information - maybe you can to check it.


    Because... process started - OK (like with known trouble), but.... if any other steps without help-points for normal load Key..... not helped.... here can be just "strange" (maybe) reasons for that.

    except any overload-things... maybe here something, which can be detected by F-Secure Key team...

  • olmiolmi Posts: 4

    Thank you for your help, Ukko. 

  • PattPatt Posts: 9

    I have downloaded (from the App Store) and am using F-Secure on my Mac Mini and my iPad.  I was able to install the newest version listed above on my Mac Mini but not on the iPad.  How do I get the 1.6.137 version for the iPad?  Thanks, Patt

  • Timo_VTimo_V Posts: 38 Former F-Secure Employee

    Hi Patt,


    Which version of F-Secure Key app do you see in Appstore on your iPad?

  • PattPatt Posts: 9

    Timo, it says 6.0.  Patt

  • Timo_VTimo_V Posts: 38 Former F-Secure Employee

    Patt, try opening Apple Appstore and clicking Updates in the bottom of the page. Can you see F-Secure Key in the list of available updates? If not, find F-Secure Key app in Appstore. Then scroll down to Information section and see what it says for Version.


    Also, what is the version you currently have installed? You can see that by launching  the Key application and from the menu selecting About.

  • PattPatt Posts: 9

    Also, what is the version you currently have installed? You can see that by launching  the Key application and from the menu selecting About.



    Hello, Timo, I show that I am using Version 1.6.137
    Thanks, Patt


  • ChrissyChrissy Posts: 438
    Hi Patt!

    Just wanted to follow up on this issue you had. Did you manage to get everything working properly?
This discussion has been closed.