Key and Opera

minimini Posts: 18

I have Key on my Win7 laptop and it worked fine with Opera ja IE. Then I updated Opera (21.0) and now there's no Key icon in the password fields. Just a moment ago I updated Key (new version was available) but that didn't help, it's a no-go with Opera. Key works with IE11.

Best Answer

  • UkkoUkko Posts: 2,895
    Accepted Answer

    Hello,

     

    So, it was not my tips :) Current one "things" I already long time not used by my "reasons".

     

    Current thing was about Google Chrome, but maybe it will be work with Opera too.

     

    You can to try do next things:

     

     - Your desktop can be with .lnk/shortcut for launch Opera.

     

     - Right-click for that picture (Opera browser) and if it will be .lnk/shortcut.. you able to see:

    Forms about object... "Here will be patch for Opera.exe"

    here you should to add -> --force-renderer-accessibility

     

    Will be next look: "Here will be patch for Opera.exe" --force-renderer-accessibility

     

    Save changes. OK. And try to launch.

    After that.. if you launch Opera by that .lnk/shortcut... Key should be work :)

     

    Maybe it's more common steps, than using command line. If you don't have Opera (which .lnk or shortcut, which able to edit with that steps). You able to do that by "Opera.exe" -> Send to desktop (like create .lnk-file).

    --------------------------------------------------

    And most important : never give up :)

Answers

  • JaysonJayson Posts: 595

    Hi mini,

    Please press Ctrl + F2 on the login page, refer this KB article for more details.

     

    Thanks.

    Best Regards,
    Jayson

  • UkkoUkko Posts: 2,895

    Hello,

     

    Also current your trouble can be related with blink-core (Chromium/Google Chrome);

     

    And it's mean... situation related with http://community.f-secure.com/t5/F-Secure-Key/Why-doesn-t-F-secure-key-work-on/m-p/47065

     

    You can try to check "chrome://accessibility" (add to address-bar).

     

    One of my devices.. with Opera here have status "off" by default, which same with situation around Google Chrome. But that device without F-Secure Key and not check it, but your description close to that situation.

  • minimini Posts: 18

    Nope, doesn't work. When I press ctrl+f2 and I get a list of sites I have saved to Key, but when I select something from there nothing happens. Nothing gets pasted/inserted to password field. Tested this with saunalahti ja younited.

  • JuhaTJuhaT Posts: 55

    Hi,

     

    I tried this with Opera 21.0. As @Ukko suggested, Opera is experiencing similar problem as Chrome at the moment. You can work around it by opening URL "opera:accessibility" in the location bar that takes you to Opera settings.

     

    Make sure that on top of the Accessiblity configurations page it says "Global accessibility mode: on". If it says 'off' then click the text to toggle it on.

     

    Immediately after doing this Opera behaved really strangely. When I closed all existing tabs and restarted the browser, clicked on the accessibility then it started to work as it should.

     

    For Chrome we've been in contact with the browser developers and they will fix the browser in few months coming. I have no idea how soon Opera will be reflecting changes done in Chrome in their browser.

     

    I hope this helps.

     

    Thanks,

    Juha

  • minimini Posts: 18

    Nope, doesn't work. I changed "Global accessibility mode:" to "on" but every time I start Opera it's off again.

    I'm running Opera 21.0.1432.67, which is the latest at the moment (I think...).

    Need to test it little more, but seems that it just doesn't work now. Hopefully Opera is going to fix this...

     

    Thanks  =)

    MiNi

  • UkkoUkko Posts: 2,895

    Hello,

     

    http://community.f-secure.com/t5/F-Secure-Key/Why-doesn-t-F-secure-key-work-on/m-p/47065

     

     

    If it not will be with "magic" around Opera (stuck with normal situation) -> try check latest posts from topic (link).

     

    Google Chrome (Blink/Chromium) dropped that behavior "remember accessibility-setting" after one of new version.

    And it able to use tips by ...... /not found how to get link for one reply/ ... so quote:

                               | Solution is to start chrome with "--force-renderer-accessibility" |

     

    If it works.. you can to read original reply on same topic.

    Current situation with "not remember", when you edit accessibility-setting.... happened with Google Chrome 33.

    Because Opera 20 based on Chromium/Blink 33 ... and Opera 20 not remember it too.

    So Opera 21 based on Chromium 34 ....  where it's still same situation.

  • minimini Posts: 18

    Hi Ukko

    Seems that you are couple light years ahead of me... =)

    Where should I insert  "--force-renderer-accessibility" ?

     

    Maybe I'm a little off my league here  Smiley Wink

    And I just should give up and start using Firefox (IE?! Thanks but no thanks)

     

    MiNi

  • minimini Posts: 18

    YES! Yeeeees! It's working :)

     

    Actually I was quite close, because I copy-pasted --force-renderer-accessibility to my Opera desktop icons target line, but missed one space after ". Bugger Smiley Wink

     

    Thank you sooo much, you are my hero :)

    Now I can continue with Opera

     

    MiNi

  • minimini Posts: 18

    And an update...

    When I open/start a new Tab that new Tabpage crashes, then I start a new Tab and it works fine. But I can live with that and can use Opera, never mind that small flaw (it's not a flaw, it's a feature  Smiley Wink

     

    So thanks again Ukko

  • UkkoUkko Posts: 2,895

    Hello,

     

    My one of devices.... have troubles about Opera 22 . So, not able to check it. But do you use Opera 22 already?! because something about "new tab" and "crash" probably was on change-logs about Opera 22. :)

     

    About other..... Nice .... that all work like can be enough for you :)

    But and I can to repeat - current one tips.. not created by me... so here need to say thanks for -> http://community.f-secure.com/t5/F-Secure-Key/Why-doesn-t-F-secure-key-work-on/m-p/49037/highlight/true#M370

     

    Like original source.

     

    After that - just your action create a good situation with your device, Opera and Key :) not my words.

     

    Anyway - thanks for thanks. :)

  • minimini Posts: 18

    I'm using Opera 23 now, and it seems that now Opera and Key are working fine together.

This discussion has been closed.