Cannot login - master password field not shown

I cannot enter the master password in F-Secure Key, since the Master password field is not shown in the application screen. My OS is Windows 7, F-Secure Key has worked perfectly before. Killing the process & restarting the application worked, but this kind of problems should not occur - not all home users know how to kill processes, and perhaps not all users have the privileges to do so.



Accepted Answer


  • JuhaTJuhaT Posts: 55 Former F-Secure Employee

    Could you check the Settings -> About and let us know the KEY version number you have running on your Windows 7?


  • TorspoTorspo Posts: 10

    My version number is 1.4.158

  • GemmyGemmy Posts: 3

    I have this issue as well. You have to kill the process and then restart Key for it to work. You have to do it every time you restart the computer.


    Also version 1.4.158.

  • UkkoUkko Posts: 3,220 Superuser



    And you also have Windows 7?



    Anyway - it's can belpful without any other reasons - - here available already new version of Key; You can also try with that (but maybe that current trouble not related with version of Key);


    Also... maybe indeed some changes in Key-service too.


    If F-Secure Key team already not found reason for that situation... maybe can be helpful:

     - do you have "default" installation-folder for Key or it's "custom"?


  • UkkoUkko Posts: 3,220 Superuser

    But.. also... doesn't matter "Windows 7 here also or not";


    If it's happened just during start/launch system and need to each time to "kill process";


    Can you to do next things?


     -  launch by command line / run -> msconfig (msconfig.exe);

     -  open "autorun"-settings and uncheck "fskey" (or from first step - by task manager-  if it's will be same with Windows 8; and here just right-click -> turn off);


    During situation, when F-Secure Key without "autorun" with launch system... can you just manual start Key-application?

    It's will be with same trouble? Or all OK? Probably... should be all "OK".

    if not - it's strange :)


  • GemmyGemmy Posts: 3

    Yes, Windows 7, 64 bit. Default installation location.


    If it doesn't launch automatically, then it works fine once you start it manually. That's sort of annoying to have to do, though...


    I re-downloaded Key and re-installed it, which changed the version to 1.5.144. Don't have time to test it out today, but will post back if that didn't fix the behavior.

  • UkkoUkko Posts: 3,220 Superuser



    Thanks for answer!


    Probably here indeed something with Windows 7; Because I can not to meet that situation with my devices (it's various, but not about Windows 7); I had experience with same trouble (but it's one-time) and it's just hang. And related with "time-out" during launch system (with overload) for autorun Key (but with latest version; previously one.. maybe can be a reason - but probably not);


    And just because.... "autorun" for Key with "turn off"-status... give situatiom, when launch Key in first time... happened without current "trouble";

    Maybe it's all related in somewhat reasons (about mechanism for autorun Key and Windows 7); Or maybe all different here :)

  • GemmyGemmy Posts: 3

    Upon restarting my computer today, Key is still working fine after autoload on startup. Seems like whatever the error was, it has been fixed in the later version of Key.

  • JuhaTJuhaT Posts: 55 Former F-Secure Employee

    Thanks for the update Gemmy, glad to hear it works. We have tried to reproduce this issue with Win7 and Win8 based on instructions provided, but without success. However the lastest improvements in v1.5 released last week apparently do help in providing solution.


    I'm still curious though; Gemmy, Torspo, what type of hard drives do you have on the computers you use? I mean the hardware design.


    Solid state disks (SSD) are much faster at boot time where as the conventional hard drives with spinning platters. The latter are somewhat slow on bootup. Ukko also mentioned that he had this once when his system was 'overloaded' at boot. This still leaves me wondering that if the system boot is slow enough, could it still interfere with the autostart.





  • TorspoTorspo Posts: 10

    I am using a conventional hard drive, and Windows does take some time to boot up due to several applications and services that I need to load at bootup.


    The problem occurred again today, but it seems that it does not occur regularly, only every now and then. 

  • UkkoUkko Posts: 3,220 Superuser

    Now.. I already can to repeat "practically each time" result of current trouble - "screenshot like";

    But in my situation..... it's require a lot of my actions for repeating without "autorun" reason. And it's indeed... practically time-out;


    Or with "autorun" by unknown certainly setting - which probably often have in Windows 7 (or something other);



  • JuhaTJuhaT Posts: 55 Former F-Secure Employee

    Thanks for all the help regarding the problem described here!


    Even if this problem was very hard to reproduce consistently we have identified the reason. Most recent versions (v1.5) did already improve situation, but not in all cases. Problem may have continued occasionally depending on how loaded the system is on bootup and what kind of hardware your computer is running.


    Next update (v1.6) scheduled for May release will resolve this.




  • tadaatadaa Posts: 8

    Well, now I have some experience of newest update.


    Program does start properly, but there are still two odd features:

    • firstly it loads an icon on taskbar during startup without loading the profram (I have decided not to load the program automatically)
    • secondly the minimize button does not work at all

    So there is left some programming work to do.

  • UkkoUkko Posts: 3,220 Superuser



    You can will try to do next things:


     - What do you mean "without loading the program"? Require about "master-password"? Because probably Key-process should be created too.

    Anyway if you don't want totally launch Key with system-start like autorun;


    You can goes to "Task Manager" and part about "Autorun", where right-click about F-Secure Key and "Turn Off";

    Or by "Run"->"msconfig"->"Autorun;


    F-Secure Key will be without autorun with system-start and you able to launch F-Secure Key in any time after launch system. And just after that.. will be "tray-picture";


    But it's will be with "require" for master-paswword. Like protection-point;




     - Minimize button does not work, but you can here use "Close";

    And it's will be like "minimize" to tray;


    For close F-Secure Key - need right-click for tray-picture and choose "Quit";



    Sorry if I wrong understand your points.

  • tadaatadaa Posts: 8

    Perhaps that autorun and removal operations work a bit differently in W8.1.


    But anyway the case was that "autorun" launched only that small icon, not the program. The situation was created in the setup process of this program where I stated that I do not want autorun.


    Now I have removed that operation and starting computer does not launch anything extra anymore - thanks. But still it would be nice if I could minimize the program running to taskbar (as in every other program is the case). Actually that small icon is unnecessary because every running program is shown in taskbar anyway (in W8.1 which I use only in desktop mode).


    This is because I use FS-Key with that ctrl+f2 way, and I do not need to see that program table at all.

  • UkkoUkko Posts: 3,220 Superuser

    About Windows 8.1 - indeed, I have not experience with current version.


    Probably next words... also will be not helpful, because maybe Windows 8.1 re-change that thing... or I a little be wrong understand some poins, but:



     - You can minimize by "close"-button in F-Secure Key Window (it's like - minimize, maximize, close);

    It's will be minimze to taskbar like tray-picture (you able to replace that from "list of programs" to "main view" like language or time information; Also probably you can to edit Windows-settings about part - which programs should be shown or not, when and how);


     - And F-Secure Key will be running during "minimized" by "close"-action on taskbar, but for certainly "active"-status need to re-change settings about Lock-time;


    Default setting - Five minutes; It's mean... when you minimize Key to tray/taskbar - it's will be locked after five minutes;


     - You can go to F-Secure Key  -> Settings  (top-left picture and here Settings-part)-> Choose "Lock-time-limit" - for example, most popular - can be Ten hours; Or more....or less.... related with your opinion "how long will be your casual session-work with computer and Key";


    After that - when Key have limit longer than five minutes.....  you able to use CTRL+F2 for fill-feature in any time, when it's not goes to automatically lock.


     - Ten hours for "automatically lock" - not critical for protection... If you go and your computer will be without you.... there have feature about "manual-lock" Key; If you want to lock it and go to do something another without worry.. that somebody can to look your passwords on your computer;



    It's mean - if autorun Key with start system already work like you want (in my experience - installer/setup was without ask about autorun-points)..... 


    Next steps just: launch Key - edit settings about "lock-time" and will use F-Secure Key :)

    Tray-picture (small picture) able to replacing for more "common"-place or stay as default - if it's not matter for you - here without any troubles;

    Just probably... some kind of trouble in current your situation - it's "lock-time", which have default-setting now.


    Sorry again - if I wrong understand. And sorry for my hard explanation.

  • tadaatadaa Posts: 8

    This minimize button  (that minus sign) does not work - suppose it should?



    By task bar I ment quick launch task bar (again W8.1), which is enough for me - I do not need to see that little icon in actual task bar because it does not increase information but takes unnecessarily space


    You can see that program is running when the quick launch icon is emphasized. This is perhaps Winows **bleep**, but FS-key should cope with it anyway.

  • UkkoUkko Posts: 3,220 Superuser

    No, here (and probably that related with Qt5 or just with Qt-platform) the minimize-button does not work and not should be.

    But here I mean - it's probably... not a situation when "should be work, but not work";

    Here "Nice if that will be work, but that not work" :)


    It's mean current status of "minimize-button" like "shadow"; Previously it was able to use... and will be just "another action", which not related with minimize (I mean - not minimize to tray, but indeed "minimize");


    About other - I will be create a private-letter for you for less words here. :)


    With current situation - probably that can be like feature or option request /edited/


  • tadaatadaa Posts: 8

    Also my problems are "history". Sometimes typing master password fails, but I think it is some kind of overload situation and I am used to it.


    It is also nice that ctrl+f2 fills up both fields (user + password).


    So I feel quite secure :).

  • AimoAimo Posts: 18

    I have this problem too, on Windows 8.1, 64bit. Key 1.5.145.


    1) It seems to be related to sleep / hibernate as Key looses its UI once the laptop wakes up. I have not done any extensive testing, but this seems to be a pattern. There's usually no problems after a full boot.


    2) I also once started Key while the background processes were still beeing started (the lovely delayed startup). The window first said "PwMgr" which then changed to "Key" and no UI.


    The processor of this laptop is just eight year old technology and perfectly good for a lot of stuff.


    I have tried killing the Key process and restarting Key but it does not help. I need to logout and login.

  • tadaatadaa Posts: 8

    My environment is quite the same (Asus A56C). In my case I do not want autoload - so there are no problems anymore - I mean slow or delayed startup is not tangling the use of F-S Key.

This discussion has been closed.