I can't log in to the F-Secure Key

I just get a blank page when I try to log into the F-secure key.
If I reinstall F-Secure Key it works until I turn off the computer. When I then turn on the computer the loginpage is blank. How can I get the program to work properly? Any suggestions?
(Windows 7)

Torspo

Best Answer

  • TorspoTorspo Posts: 10
    Accepted Answer

    This problem occurred to me today as well. Try killing the F-Secure Key process (go to Task Manager -> Processes, stop the fskey.exe process) and then restarting the application. Worked for me.

Comments

  • WilleWille Posts: 13

    Great! It works fine! Thank You very much!

  • UkkoUkko Posts: 2,974 Superuser

    Hello,

     

    Sorry for question - does it's mean that "one-time" task-kill for Key-process by Task Manager... and already all next any "launch-try" (after restart system and etc.) are work nice?

     

    Or "problem" still stay after that and just need to fix each time by "kill process"?

     

    On my systems (some - but not Windows 7) without that trouble.. (yet).

  • TorspoTorspo Posts: 10

    What worked for me was killing the process and restarting the application. No reboot was necessary.

  • UkkoUkko Posts: 2,974 Superuser

    Thanks.

    But does you mean during one session (and next session.. need to repeat current steps "killing/restarting")? Or it's totally fixed trouble in your situation?

     

    With Key - I without that situation yet (but I do not use Windows 7).

  • TorspoTorspo Posts: 10

    I do not know, as I have not yet logged out of the session where the problem occurred. So far, this problem has occurred only once for me (earlier today).

    Ukko
  • WilleWille Posts: 13

    I made a test and you have to kill the F-Secure Key process every time you turn on the computer.

    Ukko
  • UkkoUkko Posts: 2,974 Superuser

    Probably... if it's related with "repeating";

     

    Maybe you have something else (except Windows 7), which can be a reason for trouble?

     

    For example, EMET or MBAM Anti-exploit? Some protection-software?

     

    If it's just happened today (or recently) - maybe it's related with any updates for any other software?

     

    If it's something protection - it's can be a "injection" for Key-process... which create that strange situation. But I not sure... that just "killing process" can to "fix that (but if it's protection software... it's can be one-time checking/injection during session);

     

    For F-Secure AV/IS it's can be DeepGuard - you can to check DeepGuard storage (Application permissions) on Computer Security/Tools part; Maybe here have "fskey.exe" with automatic-allowed status.  And that create a some kind "real-time checking for execution/launch" - which create that "trouble";  During kill process it's some kind of "fix" (?);

     

    Maybe it's not related with that strange suggestion :)

     

    Same situation I met with any software and programs like EMET and protection-software, when "process under protection" can be a "suspicious" for another protection-software. :) and execution "hooked"

  • TorspoTorspo Posts: 10

    Could be. As far as I know, there were no updates to any software before this problem occurred.

     

    DeepGuard did not indicate the fskey.exe among the processes.

     

    Anyway, this product is now on its way out of my computer. This kind of a bug is unforgivable. I can solve these kind of problems (but do not want to), but an average home user, like my 80-year-old dad probably cannot.

     

    And I can imagine the trouble that would happen if someone actually stopped committing passwords to memory, only to have a thing like this happen and no remedy available. For me, F-Secure Key was just a tool of copy-paste convenience anyway, as I would never trust a piece of software to manage my passwords. No, committing them to memory is the way.

  • UkkoUkko Posts: 2,974 Superuser

    Yes, it's probably logical.

     

    But how... I wrote previously... current situation not repeating with my Windows-systems (it's not official supported platforms for F-Secure Key - Vista/XP some editions;   supported - and Windows 8/8.1); I trying also to "provoke" that.... but without results. Always... without current trouble (loaded nice and without blank-page, but I can not to check your screenshot yet - it's "pre-moderated");

     

    Just because... I indeed do not love Windows 7 like OS - I can not understand... what kind of problems here can be for creating that situation (and can not to check my experience with Windows 7);

     

    About your points for Key - it's close to true, but... need to say - that probably it's can not be something better - than F-Secure Key in current time. But... "can not be" - if you need something in that kind of software.

     

    What about "passwords" - I prefer to use any same software.. just with "part of my passwords" (If it's possible - did not use "full" passwords/data for storage in any places, which can be with troubles); It's some kind of helpful too :) ; But F-Secure Key.. close to best. Especially about protection user-data (any default-things, which have anyone... and some other, which just by Key and also nice).

     

    If "reason" for trouble will be "found" and it's not give for you any new reasons about your current steps - maybe you will try use Key again. :)

     

  • TorspoTorspo Posts: 10

    What is odd is that there were two of us that experienced the same problem, me and Wille. I would not be surprised if there were more people or if more people experience the problem in the near future. 

     

    I did not know that the screenshot I posted cannot be seen - I can of course see it, but no message about pre-moderation was shown to me. The execution of F-Secure Key did not hang, the login screen simply contains no text, no fields, no button. All that is there is the "Protecting the irreplaceable" text at the bottom, and the key images on the background.

    Ukko
  • UkkoUkko Posts: 2,974 Superuser

    It's indeed strange about just two people (yet) and happened:

     

     - Close to one time happened (or detected) ;

     - Same OS - Windows 7;

     

    And I can not to understand :) why it's can be - because looks that something not "locally";

     

    About picture  - maybe I wrong called that about "pre-moderation" - just it's not visible for me and maybe for any other users (except - adminstrations/moderators; and of course you can to see that like owner); And thanks for description about screenshot;

     

    Indeed... strange situation... close to "something blocking somewhat" or "broken installation"; But it's happened just after launch system-autorun? What if... just close Key (not kill) and launch again - trouble stay?

     

    Anyway.. probably it's not related with any troubles about your passwords/data. Especially in step before "master-passwords" added (all data encrypted; and after that - will be decrypted just on access.... anyway);

    If be honestly I did not use any AdBlock/NoScript.... and do not know how it works about applications (if it works) - can be a some kind of that reason (if it's create a "hidden" buttons/forms about login);  And, of course, if you and (Wille) use that.

    But strange... that happened today... and potentially without "changes" in any other software;

    Probably F-Secure Key can not "changed" automatically too;

     

    Will be good - if F-Secure Key team answered here. And good - if it's happened soon.

    Just because probably here need answer by any developers-people or any other... who work with Qt5 (like example) - maybe it's popular trouble..

  • TorspoTorspo Posts: 10

    FYI: I just rebooted my system, the problem did not repeat.

    Ukko
  • JuhaTJuhaT Posts: 55

    As found out in this thread, restarting the process apparently fixes this. Could you please let us know the KEY version number you're running? We're working on improvements and likely they provide fix for this as well. As reproducing the problem is not possible on every system, we'd need to know what version is having this problem.

     

  • TorspoTorspo Posts: 10

    My version number is 1.4.158

  • WilleWille Posts: 13

    My version number is 1.5.144
    And I still have to kill the F-Secure Key process every time I start the computer

  • JuhaTJuhaT Posts: 55


     

    There was many Community threads around this topic. Please check this thread:

    http://community.f-secure.com/t5/F-Secure-Key/Cannot-login-master-password/td-p/50083

     

    for the latest update. Could you also follow up any further discussion in that thread?

     

    -Juha

This discussion has been closed.