Key not working on Mavericks

I'm running OSX 10.9 and have been trying to install F-Secure Key.

 

I've re-installed a few times, but each time I launch, I get a blank window. The window content never loads.

 

The log file at:

 

~/Library/Application Support/F-Secure/Pwmgr/Pwmgr.log 

 

is showing the following error:

 

[16:12:49:385] -C- undefined [0] : Error: Load timeout for modules: ext/domReady,jquery,handlebars,l10n,fastclick,pwmlog,backbone,underscore,marionette,sjcl
http://requirejs.org/docs/errors.html#timeout

 

Can anyone help at all?

Comments

  • SimonSimon Posts: 2,584

    Hi, and welcome to the forum!

     

    Hopefully one of our Mac users, or an F-Secure Expert can help you out, but if you don't get a response here within 24 hours, I'd suggest throwing in a Support Ticket, or try the Chat service, if it's available.

  • SeanVSeanV Posts: 38

    Dear Zero,

     

    We might need more information to further analyze the issue. Please feel free to contact our support team and provide more information so that our Technical Expert can analyze the case and give you a solution. Below is the link to contact our support team :-
     
    http://www.f-secure.com/en/web/home_global/support/contact

     

    Please feel free to contact us again should you need further assistance.

    Thanks.
    Best Regards,
    Sean Veloo

    ..........................................................................................................................................................................................................................
    Has somebody helped you? Say thanks by giving kudos. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.


     

     

  • SeanVSeanV Posts: 38

    Dear Zero,

     

    Please accept my humble apology for the wrong information. I just noticed F-Secure Key. Please be informed that for F-Secure key, we do not provide standard phone/call support.

     

    However we will proceed to assist you via community. Also please check our help in community:

     

    Self help video available: http://community.f-secure.com/t5/Security-for-PC/How-to-use-F-Secure-Key-Self/ta-p/36417

    Public FAQs: http://community.f-secure.com/t5/Security-for-PC/tkb-p/Protection%40tkb/label-name/key?labels=key

     

    Please feel free to contact us again should you need further assistance.


    Thanks.
    Best Regards,
    Sean Veloo

    ..........................................................................................................................................................................................................................
    Has somebody helped you? Say thanks by giving kudos. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.

     

     

  • PauljPaulj Posts: 6

    I am seeing the same issue.  My Pwmgr.log looks like this.  Does the application rely on Safari in some fashion?  I have not tried running it when Safari is not running.

     

    ===== STARTED 2013-11-28 02:38:09 UTC =====
    [02:38:10:434] -C- file:///Applications/F-Secure%20Key.app/Contents/Resources/www/js/ext/less-1.3.0.min.js [8] : less: parsed file:///Applications/F-Secure%20Key.app/Contents/Resources/www/less/pwmgr.less successfully.
    [02:38:10:526] -C- file:///Applications/F-Secure%20Key.app/Contents/Resources/www/js/ext/less-1.3.0.min.js [8] : less: css for file:///Applications/F-Secure%20Key.app/Contents/Resources/www/less/pwmgr.less generated in 472ms
    [02:38:10:526] -C- file:///Applications/F-Secure%20Key.app/Contents/Resources/www/js/ext/less-1.3.0.min.js [8] : less: css generated in 473ms
    [02:38:35:760] -C- undefined [0] : Error: Load timeout for modules: main
    http://requirejs.org/docs/errors.html#timeout

  • PauljPaulj Posts: 6

    Here is some additional information on my setup.  I'm running OS X 10.9 on a 2007 iMac with 6GB of RAM.  I ran Key without Safari being active and got the same results -- empty window, and only a single Menu with a Services and Quit option.

     

    Two processes appear when Key is launched:

     F-Secure Key 64 bit
     QTKitServer-(22477) F-Secure Key   32 Bit
     
    The following messages are logged in console.log, these appear to be advisory more than errors.
     
    11/28/13 11:09:22.354 AM F-Secure Key[22477]: CoreText performance note: Client called CTFontCreateWithName() using name "FSecure Office" and got font with PostScript name "FSecureOffice-Bold". For best performance, only use PostScript names when calling this API.
    11/28/13 11:09:22.355 AM F-Secure Key[22477]: CoreText performance note: Set a breakpoint on CTFontLogSuboptimalRequest to debug.
    11/28/13 11:09:33.172 AM F-Secure Key[22477]: CoreText performance note: Client called CTFontCreateWithName() using name "FSecure Office" and got font with PostScript name "FSecureOffice-Regular". For best performance, only use PostScript names when calling this API.
    11/28/13 11:09:33.205 AM F-Secure Key[22477]: CoreText performance note: Client called CTFontCreateWithName() using name "FSecure Office" and got font with PostScript name "FSecureOffice-Regular". For best performance, only use PostScript names when calling this API.
    11/28/13 11:09:33.209 AM F-Secure Key[22477]: CoreText performance note: Client called CTFontCreateWithName() using name "FSecure Office" and got font with PostScript name "FSecureOffice-Regular". For best performance, only use PostScript names when calling this API.
     
  • PauljPaulj Posts: 6

    On another machine, my MacBookPro (13" Mid-2012, quad core i7, Mac OS X 10.9), Key runs just fine.

     

    After copying to the Applications folder, it started up and let me create a new account with no issue.

     

      application initializing, version 1.0.13

  • JaysonJayson Posts: 595

    Hi Zero,

    Please try the steps below.

    1. First close F-Secure Key application opened.

    2. Purge the application data to start fresh by rename the folder with adding ".old" in the end if you have data setup previously in this installation. Otherwise, delete the folder.

    The application data is:
    ~/Library/Application Support/F-Secure/Pwmgr

    Note: This is a hidden directory in users home directory.

    3. When you now start F-Secure Key again, it would prompt to create the master password just as with first use and the contents of the application will be empty.

    If this does not resolve the issue, kindly remove the application and reinstall with new installer download from here.

    Hope this helps.

     


    Best Regards,
    Jayson

  • ZeroZero Posts: 2

    Hi Jayson,

     

    Still no good I'm afraid. The log file show exactly the same trace:

     

    [08:38:20:012] -C- file:///Applications/F-Secure%20Key.app/Contents/Resources/www/js/ext/less-1.3.0.min.js [8] : less: parsed file:///Applications/F-Secure%20Key.app/Contents/Resources/www/less/pwmgr.less successfully.
    [08:38:20:035] -C- file:///Applications/F-Secure%20Key.app/Contents/Resources/www/js/ext/less-1.3.0.min.js [8] : less: css for file:///Applications/F-Secure%20Key.app/Contents/Resources/www/less/pwmgr.less generated in 108ms
    [08:38:20:035] -C- file:///Applications/F-Secure%20Key.app/Contents/Resources/www/js/ext/less-1.3.0.min.js [8] : less: css generated in 108ms
    [08:38:30:802] -C- undefined [0] : Error: Load timeout for modules: ext/domReady,jquery,handlebars,l10n,fastclick,pwmlog,backbone,underscore,marionette,sjcl
    http://requirejs.org/docs/errors.html#timeout
     

     

     

     

    Thanks,

     

    I.

  • JuhaTJuhaT Posts: 55

    We have been trying to reproduce this issue in house as well as with community help. The problem appears in a very small number of Maverick installations. We are still investigating the issue and testing a cadidate fix. Thanks for your patience.

  • The problem has been identified and a working solution is already tested in our beta version, it will be included in the next public release.

     

    -Mat

    Chrissy
This discussion has been closed.