mistake with update 15.30 Client security premium

Carles_Support Posts: 4 New Member
edited April 6 in Business Security

We update to F-secure Client security premium 15.30 but with the update we have the error message "Error with the work of protection. Restart computer" (Error de funcionamiento de la protección. Reinicie el equipo) And "fail searching updates. We can't make a connection with server" (Error al buscar actualizaciones. No se puede establecer conexión con el servidor)

Licence is managed by Policy Manager in a server.

Accepted Answer


  • Carles_Support
    Carles_Support Posts: 4 New Member

    Hi Sethu, thanks for your answer. Is possible you can send me the installer by email?

    Thanks again,

  • Sethu
    Sethu Posts: 724 Moderator

    Hi @Carles_Support ,

    Sure, I have now sent you a private message with the hotfix.



  • FabioRocha
    FabioRocha Posts: 4 Explorer

    Would you be so kind to send me the fix? I've multiple workstations in multiple sites that are not updating.

    Thank you

  • Carles_Support
    Carles_Support Posts: 4 New Member
    edited February 2022

    Hi @FabioRocha I have the issue 0451xxxx [ ref:_00Db0JXpV._500672U5rRF:ref ]

    I uppload the log a few days ago, please tell if you want more information.

    Thanks for your help,

    Edit: PII Removed

  • Carles_Support
    Carles_Support Posts: 4 New Member


    I try to access to Policy Manager to upload the .jar file but we have the error window "We can make a connection with server: localhost:8080. Verify hostname and port number are correct. Port number 8080 is setting by default."

    You can tell us what is the correct information?

    Thanks for your help,

  • MonikaL
    MonikaL Posts: 211 Moderator


    Ensure that Policy Manager Console and Policy Manager Server are running the same version.

    - Follow this Knowledge base Article

    If the problem still persists:

    Make sure that there is not a port conflict:

    • The host module for the PM server is running on port 80(HTTP) and 443(HTTPS) by default. Probably the port is in used by the web service.
    • I would propose to do the following:
    • 1. Run cmd.exe as Administrator
    • Run netstat -anb to find out which process is running on port 80

    • 2. Change the port number for the host module(HTTP) via the following registry, and then try to start back F-Secure Policy Manager Server service:
    • =========================================
    • HKLM\SOFTWARE\Wow6432Node\Data Fellows\F-Secure\Management Server 5
    • HttpPortNum(REG_DWORD)
    • =========================================
    • You may use the port number for example, 85, etc., which is not commonly in used. If this helps, there is port conflicts in this case which stop the PM server service to work.

    Note: if you find a conflict, you can solve it changing the ports or by uninstalling/deactivating the service causing the conflict.

  • diego_support
    diego_support Posts: 5 New Member

    Hi Sethu,

    can you send me this hotfix for this problem, I am continued with the problem that he had Carles and I needed this solution, the problem is:

    I managed to connect to the policy manager console of the server,

    I'm in touch with Jamesch on another community ticket: https://community.f-secure.com/en/discussion/124991/update-version-15-30-not-works/p1?new=1

    thanks for the help!

This discussion has been closed.