java.exe CPU on PM server



we're using PM server and console 14.20, but the f-secure clients on the servers are still using 12.12.
I just started working here in this company, so I don't know if this is an old or new issue, but I just noticed today the the PM server is very, very unresponsive due to java.exe  running from C:\Program Files (x86)\F-Secure\Management Server 5\jre\bin.  This has been going on for several hours now. Is this expected behaviour or not? Anything I can do?



  • A-GrinkevitchA-Grinkevitch Posts: 170 F-Secure Employee

    Hi Krisvdv,

    Policy Manager is the Java based application and runs under java.exe process. It is normal to have some load as it constantly processes statuses and other information hosts are pushing to the PMS. If you did not update policies recently and CPU load is high for a long time, please collect fsdiag and provide it via Support for further analysis.




  • krisvdvkrisvdv Posts: 31

    hi Alex,


    thanks for the feedback.


    I think the CPU load on the server is too high as java.exe is continuesly between 40 and 70 and very often goes up to 85-100%.   Working on the console is really difficult.


    I'll send the fsdiag output to Support.


  • krisvdvkrisvdv Posts: 31

    There seems to be a problem with the fsdiag support tool on our PM server.  I've already tried it 3 times using both the GUI and the command line, and while the screen shows "gathering information" etc,  and at the end even a confirmation "file has been put on the desktop",  the file can't be found anywhere. Not on the desktop, not in other user profiles/folders/locations. The local server disk has more than enough space.  No error, no warning, only confirmation that it's done.  Strange....
    Has anyone seen this problem before?

  • krisvdvkrisvdv Posts: 31
    This time, I'm seeing "The information was not gathered. Error occured."
  • MonikaLMonikaL Posts: 182 Moderator

    Hi krisvdv,


    If the built-in fsdiag fails, you may download the standalone fsdiag tool. Follow the steps below:


    Download the standalone fsdiag tool from:
    Double-click and run the fsdiag_standalone.exe file
    Click Run diagnostics. The tool starts to gather diagnostic information
    Once completed, it generates a file called fsdiag.7z on your desktop
    Attach the file to your email reply to F-Secure support.



  • krisvdvkrisvdv Posts: 31

    thanks, this worked!

  • krisvdvkrisvdv Posts: 31

    new problem: 

  is about 175 MB large and the support request page says "Total size of attached files should be under 100MB". 


    What can I do in this case?  Why is it limited to 100MB if the support tool can create larger zip files?



  • MonikaLMonikaL Posts: 182 Moderator

    Hi krisvdv,


    If the file size of your FSDIAG file is large, you can upload the file to our FTP site. Make sure that you have a case number before submitting the file. You will receive a case number in the email sent by our customer support.


    1. Rename the generated diagnostic file following this format: [Your case number here]_FSDIAG.TAR.GZ or [Your case number here]_fsdiag.7z
    2. Right-click the Windows Start icon, and select Open Windows Explorer. A Windows Explorer window opens
    3. Type in the address bar, and press Enter
    4. Copy the renamed fsdiag file to the window (or drag and drop it there)
    5. Reply to the email sent by our customer support to inform us that you have now uploaded the FSDIAG file.



  • hi F-Secure,

    for me, you can close this ticket.

    We added a cpu to the server and everything is running well now.

    thanks for the support!



  • jameschjamesch Posts: 290 Moderator

    Hi krisvdv


    I am glad we managed to resolve your issue.

  • MJ-perCompMJ-perComp Posts: 1,101 Superuser
    While I see no use for limiting virtual servers to 1 or 2 CPUs, as modern hypervisors assign needed ressources dynamically,

    Our recommendation is 2 CPUs if the server is dedicated to PMS and AUA.
    4 CPUs if you additionally want to run PMC on the machine as well.
This discussion has been closed.