After upgrading to client security 14.10, client shows error "Virus and spyware protection malfuncti

Hi 

 

We decided to upgrade our F-Secure solution. Policy Manager is upgraded to version 14.30, Server Security to 14.00 and Client Security to 14.10.

 

Upgrade went smooth.  After the upgrade we ran into a few problems. Some of our clients won't update. Those clients are a few windows 7, windows 8.1 or windows 10. Other clients upgraded without any incident. 

 

When i turn on a computer and open F secure, it shows as trying to update malware protection. After a few minutes it will throw a warning saying "Virus and spyware protection malfunction: your computer is not protected. Please restart your computer. Remember to save your work."  After a few reboots the issue persists. 

 

The AUA log shows:

2019-12-19 14:43:03.344 [0644.06ac] I: Connecting to fsecureserver:80/guts2
2019-12-19 14:43:03.452 [0644.06ac] I: Update check completed successfully

 

Ive tried to force the updates; ive tried to repair the installation. All with no success.

 

Can here anyone shed some light?


Thank you

Comments

  • jameschjamesch Posts: 160 Moderator

    Hi FabioRocha

     

    How many machines are affected ?

     

    Follow the instructions below one at a time and check whether it solves the issue. Move on to the next step if issue is not resolved.

    1. Check and ensure that the following services are up and running. Start the services if they are not running. Or perform reset by stopping and restarting the services manually:
      • F-Secure Automatic Update Agent
      • F-Secure Management Agent
      • F-Secure Network Request Broker
      • F-Secure ORSP Client
      • F-Secure WebUI Daemon
      • FSGKHS
    2. Download and run the FSAUA reset tool to reset the potentially corrupted definition updates. You can download the tool here: https://download.f-secure.com/support/tools/FSAUA-Reset/fsaua-reset.exe
    3. Download and run the fsdbupdate utility to install the definition updates manually. You can find the utility here: https://download.f-secure.com/latest/fsdbupdate9.exe
    4. Uninstall the product and then reinstall it using the F-Secure uninstaller tool. You can find the tool here: https://www.f-secure.com/en/business/support/support-tools
    5. Check on the IP configuration that your computer uses the correct subnet. For example, if it uses subnet /24 instead of /22, IP 10.X.240.X is not able to join Policy Manager in the 10.X.241.X destination.
    6. Reset GUTS2 folder by;
      • Perform step 1 (stop services)
      • Delete guts2 folder at C:\ProgramData\F-secure
      • Start back services
      • Check for updates
    MonikaL
  • MJ-perCompMJ-perComp Posts: 1,098 Superuser

    We have seen this problem wher the client was not able to correctly communicate with an Update Server. The installation process is 2-tier, means several modules will be fetched from the PMS.

     

    While your log says "connecting to <PMS>:80/guts2 which" looks ok, it does only mean, that the client is able to communicate to PMS, but does the guts2 server provide the updates needed?

    Check from PMC Dashboard top right box "Show Details" if all needed downloads ar available.
    grafik.png
    This is what I see:
    grafik.png


    If not, you need to fix that problem first!

    What this does not explain is why the effect is limitied to only some clients. Please find a common reason for those (or the others why they work).

    jamesch
  • Hey guys

     

    Thanks for the help. 

     

    From support I have gotten an hotfix (FSCS1410-HF02-signed.jar) and that solved the problem for most of our clients. 

     

    However i am still facing the same problem with 4 computers. Those are Windows 7. 

    Ive unninstalled, using the fs unninstaller too, installed and pushed the hotfix. For the day everything works fine until thye reboot the computer.

     

    I made a fsdiag but i dont know where to send / post it.

     

    Appreciate your help,

     

    Fábio

  • MonikaLMonikaL Posts: 106 Moderator

    Hi Fabio,

     

    You may submit a support ticket with a description of the issue via our website below:
    https://www.f-secure.com/en/business/support-and-downloads/support-request

     

    Once you have sent your support request, you will receive an automatic e-mail reply from us. The reply contains the ticket ID of your support request. Please save the ticket ID as you may need it later for reference.

     

    Regards,

    Monika

  • Thank you MonikaL

     

    Did it. Waiting for an answer.

     

    Fabio

    Vad
This discussion has been closed.