Announcement: New Knowledge Base

4 June 2020: We are pleased to announce the launch of a new Knowledge Base, Changelogs for Business Security Products, where you can find more details, such as bugfixes or new features, about the most recent releases of our business-related products.

F-Secure Policy Manager Update / Proxy Update

Hi All,

 

I'm about to upgrade my current F-Secure Policy Manager from version 12:30 to a version 13.

I've done it on my test setup with no problems, but in my production environment I also need to upgrade my proxy servers. Currently when I installed my Proxy servers I did it by following this guide:

https://help.f-secure.com/product.html#business/policy-manager/12.40/en/task_6653FE3CB6EA48B6B73DF0497F1190CB-12.40-en - and it worked like a charm.

 

My question is though, now after browsing for the latest update I do also see a "F-Secure Policy Manager Proxy 13.00".

But when I installed the Proxy servers in the first place it was by using the standard "F-Secure Policy Manager". I know I need to use the F-Secure Policy Manager 13.00 for updating my "Central" installation, but what do I do about my Proxies? Should I just use the standard one and update them? Or should I do a new installation using the Proxy installer instead?

 

If you need any additional info - please let me know :)

 

//Thanks guys...

Best Answer

Comments

  • MJ-perCompMJ-perComp Posts: 1,098 Superuser

    PM13 introduces a new Policy Manager Proxy concept that is based on a modified PM.

    Please take your time and read the new manuals to understand the full complexity of the change.

    Ukko
  • YoinkZYoinkZ Posts: 22

    Do you have a link for the correct documentation I need to read?

    Ukko
  • UkkoUkko Posts: 2,974 Superuser

    Hello,

     

    Sorry for my reply.

     

    Based on your URL from topic (and with change for build-num):

    https://help.f-secure.com/product.html#business/policy-manager/13.00/en

     

    Does it can be valid for your situation?

     

    Thanks!

     

  • Hello

    in my case i was unable to upgrade FSPM-12.40 NG-Proxy just by installing FSPMP-13.00.83039-1.x86_64.rpm

    There is error “f-secure-policy-manager-server conflicts with f-secure-policy-manager-proxy-13.00.83039-1.x86_64

    FSPM-12.40 NG-Proxy works on centos-release-7-4.1708.el7.centos.x86_64

    I try to uninstall FSPM-12.40 NG-Proxy, AUA by this help - https://help.f-secure.com/product.html#business/policy-manager/13.00/en/task_54E76E326C7C49F5B243C03A95173C52-13.00-en

    no sucess

    back to before created snapshot (vmware), and trying uninastall again

    # rpm -e f-secure-policy-manager-server

    Stopping fspms (via systemctl):  [  OK  ]
    /bin/grep: /usr/share/applications/*.desktop: Nie ma takiego pliku ani katalogu
    ********************************************************************************
    * F-Secure Policy Manager Server 12.40.81151 has been successfully uninstalled.
    *
    * /opt/f-secure/fspms, /var/opt/f-secure/fspms and /var/opt/f-secure/fsaus
    * directories might still contain some files created while using the program.
    * If you wish to completely remove the software please delete these directories
    * manually.
    *
    * If there are no programs using F-Secure Automatic Update Agent, you can safely
    * remove it from the system.
    *
    ********************************************************************************
    # rpm -e f-secure-automatic-update-agent

    Shutting down F-Secure Automatic Update Agent: [ OK ]
    Stopping fsaua
    Removing fsaua startup from boot scripts
    Removing data directory
    Removing configuration data
    Removing startup script
    Removing fsaua user

     

    SUCCESS, FSPM12.40 removed

    installing FSPMProxy-13.00

    # rpm -i fspmp-13.00.83039-1.x86_64.rpm

    Performing database maintenance...
    ********************************************************************************
    * F-Secure Policy Manager Proxy 13.00.83039 has been successfully installed.
    ********************************************************************************

     

    SUCCESS - I dont know, https://proxy_name:<HTTPS_port&gt; - not working, at FSPMS-13.00 Central server there is no new host PMProxy to import

     

    In old 12.40 was done:

    1. add admin.pub

    2. modify file fspms.conf

    /etc/opt/f-secure/fspms/fspms.conf
    additional_java_args="-Dh2ConsoleEnabled=true -DmaxSynchronousPackageRetrievalRequests=100"

    3. Use the fspmp-enroll-tls-certificate script to generate the proxy node certificate.
    /opt/f-secure/fspms/bin/fspmp-enroll-tls-certificate

  • A-GrinkevitchA-Grinkevitch Posts: 162 F-Secure Employee

    Hello tomczaki,
    Indeed PMS in proxy mode had name f-secure-policy-manager-server and that is the reason why it conflicts with f-secure-policy-manager-proxy, so it requires manual uninstallation - you did it correctly.
    I do not see in the console output “Starting fspms [OK]”. Could you please run /etc/init.d/fspms status and check if PMP is running. If not, start it please.

  • after restart CentOS, everything is OK, I think. New host PMProxy is visible in PMServer

    A-Grinkevitch
This discussion has been closed.