F-Secure Key makes Visual Studio Code freezing and unresponsive

Hi,

 

I faced a strange problem with F-Secure Key. Whenever it is open and running in the background, I can't use VS Code. I noticed it happening for different versions of VS Code starting from approximately April. Also, my F-Secure key was automatically updated during that time but the issue didn't disappear. Now its version is 4.5.112.

 

Also, I notice quite a high CPU load when KEY is open (15-20%) and what is even more confusing - KEY is leading the table of I/O reads among all applications (Performance Monitor -> Details -> Column I/O Reads). for example, right now it is the first process by this measure with 1 317 283 I/O reads, ahead of having as much as next two challengers together - Chorme.exe, Slack.exe.

 

My theory is that KEY misinterprets VSCode tabs as one big auto-fill field and constantly parses it causing enormous loads for the system.

 

I'm running windows 10 Enterprise 1703 x64.

CPU: Intel i7 5600U, 2.6 GHz

RAM: 16 GB 

 

Thanks for your help!

Ukko

Comments

  • UkkoUkko Posts: 2,988 Superuser

    Hello,

     

    Sorry for my reply. I'm also only F-Secure user;

     

    Your experience most likely indeed based on "autofill"-feature (or directly "System autofill"); Probably there also was topic about "Visual Studio and Key" (but I did not find it briefly?!);

    I not sure about any workarounds or fix-steps (except "disable" system autofill option - if it not disabled yet); Or 'Close' (Quit) F-Secure Key - when not expected to use it soon;

     

    One of recent topics about related concern (where also was some unofficial meanings/suggestions):

    https://community.f-secure.com/t5/F-Secure-KEY/F-Secure-Key-using-too-much/td-p/95300

     

    // Also - latest build of Key for Windows is 4.6.107 (probably); You able to download it and re-check if there any changes. But most likely.... situation will be with previous view;

     

    Thanks! 

     

    doshch
  • doshchdoshch Posts: 2

    Thank you for your answer!

     

    Do you know if it is possible to exclude this particular application from the autofill?

  • UkkoUkko Posts: 2,988 Superuser

    @doshch wrote:

    Thank you for your answer!

     

    Do you know if it is possible to exclude this particular application from the autofill?


    Hello,

     

    I able to think that - not possible (at least, with common steps);

    Spoiler

    Maybe because F-Secure Key do not "detect" certain application for 'system autofill';

    But if this is technically possible -> I not sure why F-Secure Key do not "disable" autofill for Visual Studio Code by default (because... most likely... not expected that we have to use autofill feature under this software -- but maybe required login at first?! or with certain editions);

     

    But if your situation indeed based only on "System autofill" option:

    "system autofill" will provide ability to use shortcut "CTRL+F2" (and fill credentials under text-forms; or with additional "CTRL+entry" for password-only; "SHIFT+entry" for login-name-only); And ability to use autofill under system applications (for example, it can be Steam or something like this); Maybe useful for Internet Explorer (Key extension is not provided);

    If you do not use it often -> maybe it possible to disable only "system autofill" and use F-Secure Key on-demand for such situations (like "copy" from list and add under application) - since it also will be more secure and 'friendly';

    Also maybe good to try use F-Secure Support Channel:

    https://www.f-secure.com/en/web/home_global/contact-support

    Chat (?!) with Key-based ask. Because -> maybe they able to create any fix/investigation about such situation. Why it freezes; does it should be like this... what if there is available any workarounds; Or even more -> add certain options (like exclude certain applications from autofill);

     

    Thanks!

     

  • LakshLaksh Posts: 4,431 Community Manager

    Hi doshch,

     

    Based on your post, this seems very similar to the issue shared here. It was recommended to disable the system autofill feature.

This discussion has been closed.