Announcement: New Knowledge Base

4 June 2020: We are pleased to announce the launch of a new Knowledge Base, Changelogs for Business Security Products, where you can find more details, such as bugfixes or new features, about the most recent releases of our business-related products.

F-Secure Computer Protection: Supported Operating Systems, Browsers, and Languages

Supported Operating Systems

 

  1. Windows 10*
  2. Windows 8.1*
  3. Windows 7, service pack 1

* Does not support ARM based tablets.

 

System requirements

 

  • Processor: Intel Pentium 4 or equivalent (processor must support SSE2).
  • Memory: 1 GB or more.
  • Disk space: 1.2 GB of free space.
  • Internet connection is required in order to validate your subscription and receive updates.
  • Javascript must be enabled in the user's browser settings to enable active block pages.

Supported Browsers

 

  • Edge (Windows 10). Does not support extensions.
  • Internet Explorer 11 (Windows 8.1).
  • Internet Explorer 10 & 11 (Windows 7).
  • Chrome, two latest major versions.
  • Firefox, two latest major versions.

Supported Languages

 

The product can be installed in the following languages: English, Czech, Danish, Dutch, Estonian, Finnish, French, French (Canadian), German, Greek, Hungarian, Italian, Japanese, Norwegian, Polish, Portuguese, Brazilian Portuguese, Romanian, Russian, Slovenian, Spanish, Spanish (Latin America), Swedish, Turkish, Traditional Chinese (Hong Kong), Traditional Chinese (Taiwan) and Simplified Chinese.
VadUkkoLakshJulio_Haken
This discussion has been closed.