F-Secure Key Premium 4.6.1 repeatedly closing

Hi,

 

I have a Samsung Galaxy S7 with latest updates, also Key is the latest version from Google Play.

 

Installation is simple, I can join the device with existing one (Windows PC) but Key then starts crashing before giving the device code to PC software. Also, when normally starting Key, it closes and notifys with two options, either restart app or send feedback. The second time the notification pop up says "close the app" and option two is "send feedback".

 

I've tried a couple of fresh installs. Android Webview is disabled by default. In developer settings I found two lines: WebView Initialization (Chrome Stable) and WebView multiple processes (Off). I'm Finnish so I guessed the english counterparts :) First line is not changeable and the latter either on/off won't do a thing.

 

I cannot think of any compatibility issues. The Problem has existed for some time now but I finally decided to post here instead of waiting any update.

 

Thank you.

 

-t

aba1azizi2

Best Answer

  • LakshLaksh Posts: 4,432 Community Manager
    Accepted Answer

    Hi telescope,

     

    Based on your description, this issue seems to have happened before as mentioned in this post. The latest version of KEY has the fix for this. However, since you are using the latest version 4.6.1 and the issue persists, I would recommend to contact our support team via chat or phone to troubleshoot further.

Comments

  • Hi Laksh & all,

     

    Thanks for the reply. I tried the chat but it was not available. I should've tried the contact number but kinda forgot (2 shift work).

     

    The problem has been solved, but I don't know how. If Key was updated this week, I've missed it and if it was an Android update, I have not paid much attention to them either. No other app is related to or dependant of Key.

     

    Edit: It seems that Key has been updated (now 4.6.2) and it's as good as ever. I couldn't find a change log yet to see what the update fixed. I accepted your reply as a solution to the problem. It's propably the best way to solve a problem anyway if you can't find any similar problem or have a hard time while searching :)

     

    Thank you!

     

    -t

    Ukko
This discussion has been closed.