Problem with accessing my NAS behind Sense via DynDNS

trotzendorff Posts: 13 Observer

Hi there!


I just installed the Sense at home and so far everything works fine. Now I want to connect my Synology NAS to the Sense to also protect it. To date this NAS was reachable via DynDNS, wherefore I used port forwarding at my FritzBox. Simply connecting the NAS via LAN does not work, so I tried opening the same ports at my Sense, but this also doesn't work.


Therefore I'd like to know, if anyone here can help me with that. Is an access on my NAS via DynDNS behind the Sense possible? And if so: Which settings have to be made?


Thanks in advance!



  • _UrsusCatulus_
    _UrsusCatulus_ Posts: 21 Explorer

    Not sure if this helps, or is your problem at all.

    I had problem connecting my Synology NAS to SENSE at first because I forgot I had set a static IP in DSM.

    Since SENSE uses another subnet (or what it is called) the NAS didn't show up, but as soon as I set it to dynamic (get IP from DHCP) it was back up and running. And it was better than before as it had a nasname.local address so I didn't have to remember its IP on my local LAN anymore.

  • _UrsusCatulus_
    _UrsusCatulus_ Posts: 21 Explorer

    After more checking looks like one of my Synology NAS'es are having similar problems to yours.

    My DS216j is accessable via its dyndns address, but my DS1813+ is not. So might be more to it than initially looked like from my end.

    I've tried changing the port on the DS1813+ to the original (5000, 5001) and not even then did it respond using dyndns ( address (just tested to see if I had set it to something SENSE didn't like).

  • Unknown

    Check your firewall settings from DSM.

    And you want to use an static IP on the NAS, just pick some ip from the Sense's subnet outside the Sense's DHCP pool, for example

    Also if you have 2 routers and the first one is not in bridging mode, then you have to first port foward ports from it's settings to Sense's ip address and then port foward from synology's IP address from sense settings.

    If you leave your synology to get IP from DHCP, then sometime in the future it might change it's ip address and then the port fowarding will stop working since usually it is pointed to just some static ip address since you do not want to open a specific port(s) to all your home devices from internet.



    An example setup:


    WAN router subnet:

    Sense router subnet:


    Wan router's ip address:

    Sense router's WAN ip address:


    Synology nas ip address:


    Port fowarding settings:

    From WAN router port foward port 5001 to Sense router's WAN ip address:

    From Sense router port foward port 5001 to Synology nas ip address:

  • trotzendorff
    trotzendorff Posts: 13 Observer

    Thanks for all your answers. I tried it the way 1sk proposed, but unfortunately it still doesn't work.


    The actual setting is:


    1. Router is not in bridge mode

    2. Sense has a static IP address

    3. Ports are forwarded from the Router to the IP of Sense

    4. Same ports are forwarded from Sense to the IP of the NAS


    Should work, but it doesn't. :/

  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    Thanks for reporting this,


    It's a use case we have not specifically tested, so I cannot say off the bat what could be wrong.

    Are you able to forward those ports if SENSE is your primary router (set the router in front of SENSE to bridge mode)?


    SENSE does not currently have any native support for configuring DynDNS features.


    Best Regards:

    Simo / SENSE QA Lead

  • trotzendorff
    trotzendorff Posts: 13 Observer

    Thanks for your answer Simo!


    If I want Sense to be the primary router, where do I enter the credentials for my internet connection?


    Another problem is, that if I plug the NAS back to the router, it's not reachable (via AFP or for my Time-Machine-Backups) in my local network anymore. Any chance to fix that?

  • KennethN
    KennethN Posts: 47 Enthusiast
    I have the same issue as you, following the thread.
  • Math916
    Math916 Posts: 5 New Member

    I face the same problem.

    Either I connect my NAS to Sense and can reach it for my internal network but not from the internet, or I connect the NAS to the web box and in that case I can access it via internet but not on the local network.


    Very interested in a solution on that problem.

This discussion has been closed.