Product Version Not Updating in Policy Manager

We have pushed out the install of Server Security Premium 12.11 and all servers restarted but under Status > Installed Software on the PM it still shows the previous version of 12.00.

 

If I uninstall FSecure Premium on the server completely and reinstall it, it will then show the correct version in PM.

 

Is there a workaround for this rather than me uninstalling and reinstalling on every server?

Comments

  • VadVad Posts: 1,051 F-Secure Employee

    Hello Marcrp,

     

    Please, do the following on one of affected servers:

    From c:\Program Files (x86)\F-Secure\common\  execute a command "polutil dump <some folder>\policy.txt", and find a string "1.3.6.1.4.1.2213.77.2.1" in generated policy.txt. It should contain current product version. Is it 12 or 12.11?

     

    Best regards,

    Vad

    etomcat
  • MarcrpMarcrp Posts: 12

    Hi

     

    The output shows 12.11 on the affected servers.

     

     

  • VadVad Posts: 1,051 F-Secure Employee

    Thanks for checking. That means the client side reports a proper product version to PM.

    What is your PM version?

    Also, please, check, if policy changes can reach affected servers, in order to exclude possible communication issues.

     

  • MarcrpMarcrp Posts: 12

    We are using PM 12.40.

     

    Yes the PM changes are being deployed to the clients OK.

  • A-GrinkevitchA-Grinkevitch Posts: 162 F-Secure Employee

    Hello Marcrp,

    Could you please collect two fsdiags: one from the Policy Manager host and second from the host with Server Security Premium that was upgraded to 12.11 (rebooted if needed) but still reports 12.00.
    To collect those, please start F-Secure Support Tool from your Start menu – it collects package called fsdiag.tar.gz to your desktop. You can share these fsdiags via F-Secure Support for further investigation.

    TIA,
    Alexander

    Laksh
  • MarcrpMarcrp Posts: 12

    Thanks, I have done the fsdiag on both PM and a problem Server and logged a support call.

  • A-GrinkevitchA-Grinkevitch Posts: 162 F-Secure Employee

    Hello Marcrp,

    Now it is clear what has happened... You had Server Security 12.00 installed and upgraded it to Server Security Premium 12.11. Seems installer did not clean status from the previous installation, thus computer reports two versions:
    12.00 (1.3.6.1.4.1.2213.67.2.1) and 12.11 (1.3.6.1.4.1.2213.77.2.1). PM can show only first one in the Status Standard view. If you open host's status in Advanced view, you should see both product MIBs marked as bold with corresponding versions.

    Laksh
This discussion has been closed.