Incorrect Master Password

Since today I cannot logon to F security Key anymore on my Android 6.0.1 Galaxy A5 device. It always says "Incorrect Master Password". Untill today it always worked. In an attempt to fix this I have re-installed the app, entered the sync code generated on my app on my PC, entered the master password and the device is synchronizing and all passwords are there. It seems to work. However, if I lock the app and try to logon again, I again get "Incorrect Master Password". I have also changed the masterpassword on my PC where everything works fine but still get "Incorrect Master Password" on the Android. Very odd, what can the problem be?  



  • NäsäviisasNäsäviisas Posts: 780
    Hello Pete

    Is it possible, that
    - when logging in, caps lock, and password wrong
    - you have used the usuals password when logging into master, if you have two signs
    - someone has broken to your Galaxy and then changed password?


    Many keydocuments in Community,
    Copy of text:
    If you have earlier created master password recovery code, you must create a new master password recovery code for the new master password.

  • pete61pete61 Posts: 4


    Thanks for your quick reply.

    Potentially could someone have broken into my galaxy and changed the master password. But the password still works on all other devices. Is there a local copy or something of the password on the Galaxy that could have been changed? And how could someone change the password with knowing the old? Is there any malware  on android known to do this kind of things?


  • NäsäviisasNäsäviisas Posts: 780
    Hello Pete again

    Read above mentioned article, mentioned KEY-FILE. In the other case, KEY-FILE was a solution.
  • pete61pete61 Posts: 4

    Yes I read the article but this key-file issue is for a pc, I have the problem on android.

  • NäsäviisasNäsäviisas Posts: 780
    You can take contact to F-S Chat Support
    or call Support, too.
  • UkkoUkko Posts: 3,198 Superuser



    Since there missing feedback from you (does there was successfull experience with direct F-Secure Support Channels: Chat or Phone ?)  and missing some F-Secure Key Team replies (yet)...


    Sorry for some of my suggestions (also as additional to discussion under this topic):



    --> Just because you noted that reinstall/resync was helpful, BUT 'lock the app' and logon again = break it:


    What if there trouble with recent builds of F-Secure KEY and such situations (?!). Can be useful - if someone else will reply there (if he experienced this situation also).


    --> Just as clarification about your latest noted steps:

    When you change masterpassword under desktop - most likely that it should be with changes under Android device; So it will be expected to use 'one masterpassword' after 'sync-process' and with related prompt (of course, - if you do not mean that you add under Android device 'fresh masterpassword', but it not allowed);

     --> If there stuck with localstorage under Android device (as result 'stuck' for masterpassword and broken view);


    But firstly as potential workaround or re-check steps:


    F-Secure Key with QR-recover code feature (if I normally remember) - since you did not try it (or did note it) probably you did not use it.. but if you previously created such recover QR-code under your Android device. Maybe you able to re-check - if it still valid/work (?!):


    But as it noted there under article - with each masterpassword-change -> QR-code start be not actual. As part of research - you able to perform steps like:

    --> reinstall F-Secure KEY app -> sync devices -> when all OK under F-Secure Key -> try to create Recover QR-Code for masterpassword

    --> lock F-Secure Key and if there will be trouble with using masterpassword - re-check step with 'forgot masterpassword' and using QR-Recovery-Code. And check what will be there (?!).




    With my own experience (I used 'premium' F-Secure Key with some of previous builds) and I remember one topic-situation under community (also about some of previous builds; one of first builds):


    there was such stuck with masterpassword under some of devices (or under Android device); community-topic was with not visible reason (or proper fix-steps); But later - I eventually repeat it and got potential steps for such view. It was not known for me - even it was 'investigated"  or not... and also I not sure if it potentially possible to repeat with current F-Secure builds.

    But if I normally remember (except certain fix-troubles) such stuck was partly related with 'sync'-troublestuck (like double re-sync. if we re-change multiple times masterpassword per small time - but sync process not properly handle it)

    But your words about 'random' stuck for one device...  where possible suspect some other troubles (as something broken under device; as localstorage for F-Secure Key app); And I think you able to re-check some points... but good to have  backup (or exported file from Key) for your entries .. for preventing some unexpected situations (while there can be delay with official response from F-Secure Team based on weekends);


    Sorry for my reply.



  • LakshLaksh Posts: 4,444 Community Manager

    Hi pete61,


    Is it happening with any other android devices, if you have?

    What is the version of Key in the Android device?

  • pete61pete61 Posts: 4

    It is getting worse and worse. I have key on 4 devices, including my Andoid. Now does it only work on the PC where I changed the master password. On all other devices, PC as well as android I get Incorrect Master Password  

    The version that (still) works is 

    4.5.116 on a Windows 10 machine. 

  • NäsäviisasNäsäviisas Posts: 780
    Take contact to F-S Chat or call a phone.

    Good day, in any way!

  • LakshLaksh Posts: 4,444 Community Manager

    Hi @pete61,


    I have escalated this post to our support team as this needs further investigation from them. One of our support team members will get in touch with you for further troubleshooting via email.

This discussion has been closed.