Upgrade from FSPMS 9

Hello,

 

One of our customer still have a Linux Policy Manager Server in version 9.

 

We would upgrade this server to the version 12, but the type of database have changed in version 10, unfortunately the upgrade was not this simple, after the update, the server was in a "clean install" state.

 

Maybe we have to update to the V10 before ? Unfortunately i don't find any FSPMS 10 for linux.

 

How can i upgrade this server ?

 

thank you

Best Answer

  • MJ-perCompMJ-perComp Posts: 1,098 Superuser
    Accepted Answer

    While indeed PMS V10 in some first Version had a migration tool, the last 10.43 readme states:
    Note: Upgrade from Policy Manager 9.00 and prior versions which used the communication directory (aka CommDir) to store all the data is not supported.

     

    Also I remember that the conversion was tricky and often failed.

     

    The whole idea sounds pretty bad to me and I would rather suggest to start from scratch. There have been so many changes between V9 and V12, including 2 database changes (the third to mysql comming up) and changes in settings - you do not really want to go that way.

     

    If you want to use sneekers or some software mangement to roll out V12 depends on the size of your installation, but use the UI-Tool first, then reboot and only now install V12.31.

    etomcat

Comments

  • etomcatetomcat Posts: 1,318 Superuser

    Hello,

     

    At least the previous major version of FSPM Linux still doesn't support upgrade from the old version FSPM 9.0:

     

    "fspm_linux-11.31-rtm-release-notes.htm:

    F-Secure Policy Manager version 11.31 on Linux

    Product Release Notes
    Section 5.6: Upgrade
    ... Note: Upgrade from Policy Manager 9.00 and prior versions which used the communication directory (aka CommDir) to store all the data is not supported..."

     

    Maybe FSPM 10.x for Linux would work but I no longer have that info saved.

     

    Best regards: Tamas Feher, Hungary.

  • makzmakz Posts: 2

    Thank you that was i tought.

     

    Is someone have a link for a previous version who support the upgrade from 9.x ?

     

    Thanks a lot !

This discussion has been closed.