Software updater Not Installed on client.

Hello,

 

Working in F-secure Policy manager I was doing Client security upgrades to version 12.31 wih push installs. Updates went flawless but in my console it shows that Software Updater in not installed, but while doing the push install i made sure Software Updater was selected to be installed with the whole package. 

 

Anyone know what is wrong and how to correct the issue... 

 

Regards

Dejan

Best Answer

  • etomcatetomcat Posts: 1,318 Superuser
    Accepted Answer

    Hello,

     

    > doing Client security upgrades to version 12.31 with push installs

     

    This is bad idea, as version upgrade is integrated to the Console and works with policy based commands, so there is no need for Push Install. However, only Standard Edition to Standard Edition and Premium Edition to Premium Edition upgrades are possible.

     

    > while doing the push install i made sure Software Updater was selected to be installed with the whole package. 

     

    If you were not Premium previously and you used FSCS Standard Edition, then I think it should be uninstalled from endpoints before installing FSCS Premium, because they are different programs.

     

    Best Regards: Tamas Feher, Hungary.

    BenMJ-perCompDeang

Comments

  • DeangDeang Posts: 8

    Ok small update on the matter. I am new to F-secure so i checked im not doing push installs im upgrading software through policy manager as it is supposed to be done... so that is ok. But yesterday i did another upgrade and i checked I am installing Premium software and i checked we have premium license. But software upgrader still shows in Policy Manager as not installed.

     

    Regards 

    Dejan

    etomcat
  • DeangDeang Posts: 8
    Figured it out with F-secure support... Thank you for your reply. Was great pointers for figuring it out.

    Regards,
    Dejan
  • MJ-perCompMJ-perComp Posts: 1,098 Superuser
    Would be helpfull for others to know the cause...
  • DeangDeang Posts: 8

    Oh yeah right. Biggest problem was that i am new in the company and kind of resumed the work on F-Secure. My boss stated that we have premium code... he was sure of it. More i checked more i knew something doesnt add up. 

     

    The tricky part was that when i was installing software upgrade it was a Premium client and it gave no errors in return only success. And I had no clue that under install tab it actually says that intalled client is premium because i never sam that.

     

    So we called local support and he checked and then explained that we indeed have a Standard serial and not Premium. But he also was confused as in why didnt the install return an error given that not all features were actually installed.

     

    To recap was told its premium...it was not. Hard to prove it if you are clueless. :)

     

    Thank you

    Regards

    Dejan

This discussion has been closed.