Key Premium doesn't work on PC

I have Key Premium and it work fine on mobile phone and tablet. For some reason on PC it says Key Free and doesn't sync. The problem is that most of the time I add new passwords or change them on PC. The problem occur when they are not available on mobile or tablet. How can I update the Premium version also to the PC? I cannot find such function from there.

Stedi

Comments

  • LakshLaksh Posts: 4,434 Community Manager

    Hi TeroAatos,

     

    May I know if there is any error message when you try the sync? Have you upgraded to Key premium on your mobile/tablet? If yes, you can just sync it with your PC for activating the sync as mentioned in this article.

  • Hi,

     

    Thanks for your fast response.

    I have Key Premium on my mobile&tablet (already for years). Both devices shows that Key Premium is "active". I have had the Key Premium on my PC in years (and used it) but for some reason now it has changed to Key Free.

     

    I followed the instructions from the article and created the sync code on my mobile where is Key Premium. Then added that to the PC. When I first pushed the connect button nothing happened. When I pushed it again I got error message: "Server connection could not be established. Check your internet connection and sync code".

    Well, internet connection is working and sync code was correct.

     

    How this can be fixed, thanks.

  • LakshLaksh Posts: 4,434 Community Manager

    Hi TeroAatos,

     

    I could find 2 related KB articles regarding the sync connection issue with Key. Please have a look:

     

    https://community.f-secure.com/t5/F-Secure-KEY/KEY-sync-connecting-devices-with/ta-p/70031

    https://community.f-secure.com/t5/F-Secure-KEY/Why-can-t-I-sync-F-Secure-KEY/ta-p/80612

     

     

  • Hi,

     

    Thanks for the articles.

    I read those and try those solution but as I have the Key on my work computer our IT department does not accept those solutions.

    So is the situation that I have now lost the options and just cannot update Key Premium to my work computer?

    As said I have had that for year on my work computer but it seems that our company has changed the anti-virus program (now webroot) and it cause these problems.

  • LakshLaksh Posts: 4,434 Community Manager

    Hi TeroAatos,

     

    I guess, in your case, it might be the new AV which might be blocking the sync. If you are unable to access https://avain.f-secure.com, then it might be the AV which is preventing it. Could you check with your IT department on this to configure the AV to allow https://avain.f-secure.com?

     

  • Hi,

     

    Thanks.

    I contacted again to our IT department and one guy was nicely helping me.

    After few checking his response was:

    "The address itself is ok, we don’t block that. So there is something else within the sync that creates “the struggle”.

     

    So from that point of view I understand that our company does not block that https://avain.f-secure.com.

    And the guy who was helping me is nice guy and I know he really checked what he could.

    Is there anything else anymore that could be checked?

     

    I also tried to export those password for a file but I cannot get it out in any readable format. I cannot find program which support *.fsk file. And when exportet it to anyother files it's not readable. I tried this so that if syncing cannot be done I have to check the passwords one by one and that's why wanted to print them out.

     

    Thanks if you could give me once more some support :)

  • LakshLaksh Posts: 4,434 Community Manager

    Hi TeroAatos,

     

    Since you mentioned the address is not being blocked, have you checked if switching off https protection in your Anti-Virus product helps (with the IT team)? I might recommend to contact our support via phone/chat in order to get some further inputs about the sync issue.

  • StediStedi Posts: 8

    I have exactly the same problem. Key stopped working on PC and shows as FREE and does not allow sync. 
    Meanwhile Key works fine in my tablets and phones.

  • StediStedi Posts: 8

    No luck with sync, even when I've

    whitelisted the https://avain.f-secure.com URL  in SAFE
    uninstalled browsing protection

    disabled f-secure SAFE 

     

    even uninstalled Key and re-installed. 

     

    Was not able to uninstall the F-Secure Key User Data from PC, the uninstaller does not find the uninstaller. 
    Where is the data located, can I just delete it from the hard-drive?

  • StediStedi Posts: 8

    OK, now it works, kinda. 

    Managed to remove the User Data by tweaking Windows Registry, deleting all references to Key 
    Installed Key

    Uninstalled Key
    And now managed to Uninstall User Data

    Installed a fresh Key with no User Data and now could sync with my tablet. 

     

    Tested that sync works, if I add an item in the tablet it will show up in PC

    BUT in PC's Key it reads KEY FREE in the program left bottom area. 

    odd

     

  • SkeleSkele Posts: 3

    I'm having the same isseu but in my case the is an Android device, iOS device and two Windows 10 desktops involved. The sync just stops occasionally with the one or both of the desktops.

  • BenBen Posts: 2,641 F-Secure Product Expert

    Hi Skele, 

    Is the sync restarting by itself or do you need to do something so that your PCs get back in sync?

     

    @stediCould you confirm that your PC syncing is still stating "Free"?

  • SkeleSkele Posts: 3

    Thanks for the quick reply! No, it's not restarting. The Windows client says it's using the free version and not the premium.

  • StediStedi Posts: 8

    Yes, still reads KEY FREE in PC but Premium in my 2  Android devices.

    I've done some testing too and found odd behaviour between devices.

    If I add a password in either Android devices it will get synced into PC.

    If I add password in PC it will NOT be synced into Android devices. 
    Also if I delete password in PC it will not be deleted in Android.

     

    rgds Stedi

    Skele
  • SkeleSkele Posts: 3
    This is exactly what I'm experiencing as well.
  • BenBen Posts: 2,641 F-Secure Product Expert

    In order to better investigate this issue we will need logs from your installations, could you get in touch with our support via chat or phone

  • StediStedi Posts: 8

    OK Problem solved. 
    My subscription had just expired. 
    Funny that only PC version showed KEY FREE and remaining mobile devices showed still a valid subscription. 
    You should correct the mobile apps also to inform correctly about subcription validity. 

    I've renewed the subscription and everything sync ok.  This is a great program, I have more than 100 different passwords, could not manage without this.


    One odd thing still remains, the validity date's year is gibberish, for me it is 29.3.45941  or then I really got a great extension to my subscription :)

This discussion has been closed.