Autofill function for CHrome

Ben Posts: 2,641 F-Secure Product Expert

Hi all,


We have a new F-Secure KEY preview release available with autofill using a Chrome extension. Other browsers will follow.


You can download the Mac or Windows version here:


Once the new version in place, you will need to install the extension.

-Open KEY

-Navigate to Settings -> General and

-Click the button "Install Chrome extension"


If Chrome is not your default browser, open this url to install the extension:


After installing the extension it needs to be authorized with the KEY client. 

-Copy the authorization code from the KEY Settings page

-Enter it to KEY extension by clicking KEY icon in the top right corner in Chrome browser.


KEY icon should start appearing in username fields on the websites, click the icon to select proper credentials and login.


Please provide feedback by replying to this thread.


Note that KEY Chrome extension is not always able to recognize login forms on websites where login is done through pop-up dialogs.


  • cageyr
    cageyr Posts: 2 New Member

    Working nicely on most sites I use. Issues with two banking sites: - no key icon in username field and ctrl+F2 does nothing; - 2nd page of login (passcode and reg number) - no key icon in passcode field and ctrl+F2 does nothing.

    Neither site is using popup dialogs for login.

  • TheoGray
    TheoGray Posts: 17 Explorer

    Mostly working very well and a big improvement on previous functionality Smiley Happy


    I have found that where the username field has a


     attribute, this seems to stop the key icon appearing. If I remove the attribute using Chrome dev tools, the icon appears straight away and works fine.

  • bobbers
    bobbers Posts: 6

    RE: up-grade to version 43130:


    I've tried any number of tmes to authorise the Chrome Key Extension, but every time, I get stopped with "paste". I copy the authorization code, open the browser window for the code by clicking on the Key icon, and a box appears, but there is no way to paste into it. As soon as i try to use "paste", the window disappears. I think that during one of my earlier efforts, the Key icon lit up briefly, but during my last dozen attempts, it remained gray. What am i doing wrong?


    [email protected]


    EDIT: Removed PII

  • bobbers
    bobbers Posts: 6

    Thanks for the quick reply. I have done it all - uninstall and re-intstall. Used the pop-up asking me to up-grade and also the earlier one I am replying to. But every time I get to the point where I am asked to copy a long alphanumeric authorization code, I do so. It is confirmed. So now I have it copied and ready to be pasted. I open the browser, click on the F-Secure logo, and a window pops up which seems to me where I should paste the copied code. But there is now way to paste. Each time I ask the browser to paste, the window needed disappears, and I am stuck.

    What do I need to do differently?

    [email protected]


    EDIT: Removed PII

  • TheoGray
    TheoGray Posts: 17 Explorer

    When working with development websites running on localhost:portnumber, over the past couple of weeks (Chrome 52.0.2743.116 with KEY extension v0.9.9.4 and KEY v4.3.131) I am getting "No matching entries. Please ensure the URL is correct or add domain name to the entry title in KEY."

    F-Secure Key message when accessing site on localhost

    The URL of localhost:portnumber in KEY used to be enough, but I have also tried adding http:// to the front and putting in the full login page URL, but these don't work either.

  • Laksh
    Laksh Posts: 4,444 Former F-Secure Employee

    Hi TheoGray,


    If you have already tried to put the full login URL in Key (as seen when you open the website), and the issue persists, I would recommend to open a support ticket with our team for further investigation.

  • I have tried to install the newest addon 0.9.9 in both firefox and in chrome.

    In Firefox it doesent show up as an icon after i installed it exept if i go in under addons so it dosent work at all.

    In chrome i can install it and it show the icon were i shall fill in the the authorization code but it dosent work and sas its unvalid.

    Key: 4.3.119
    Firefox: 48.02
    Chrome: 53.0.2785.101 m (64-bit)
    Win: 7

  • Ben
    Ben Posts: 2,641 F-Secure Product Expert

    Hello Rikard, 


    It looks like you are using an older version of KEY. Could you upgrade to the latest version to see if your problem persists.


    The current version is 4.2.137.


  • Hey Ben,

    Thanx for the fast reply.

    It solved the problem with chrome and its working just fine now.

    But in Firefox i dont know were to put in the code.
    There is no f-secure key icon like in chrome.

  • Ben
    Ben Posts: 2,641 F-Secure Product Expert

    You can refer to this article on how to install the KEY extensions.

  • Hey,

    The Icon showed up in the menu after restarting my computer 3 times.

    So now ewerything working correctly.


  • I am testing KEY on Chrome (extension loaded). AutoFill works well with all other sites I have tested but not with, neither does ctrl+F2.


    Any ideas what it is all about ?

  • Truth
    Truth Posts: 10

    It is not working.  Do you need the premium verison or will it work with the free verison?

This discussion has been closed.
Pricing & Product Info