Announcement: New Knowledge Base

4 June 2020: We are pleased to announce the launch of a new Knowledge Base, Changelogs for Business Security Products, where you can find more details, such as bugfixes or new features, about the most recent releases of our business-related products.

"Windows Installer service could not be accessed" Message while installing F-Secure Server Security

Hello guys

 

This week I accessed F-Secure Policy Manager and realized that one of the servers hadn't been in contact with  Policy Manager for a while. When I accessed the server, I discovered that F-Secure Server Security was not installed anymore. It was strange because I didin't uninstalled it or tried to update it.

 

The server is running Windows Server 2012 Datacenter (core) operating system. I tried to install FSSS using the Policy Manager Console but it didin't work. Then I tried to do so using a msi file that I used in other severs before, but it didin't work either. The following message appeared:

 

"The Windows Installer Service could not be accessed. This can occur if you are running Windows in safe mode, or if the Windows Installer is not correctly installed. Contact your support personnel for assistance."

 

I generated other msi files of F-Secure Server Security 10.01, 11.00.739, 11.01.157 but the error message was the same. I also tried to peform the tasks shown in some Microsoft KBs like https://support.microsoft.com/en-us/kb/315346 about Windows Installer but problem persisted.

 

I used the command msiexec /f [FSSS Package] and a message returned saying it was not installed, then I tried again install it through console and manually, and i didin't work.

 

What's curious about it is that I'm able to install other softwares using msiexec /i command. I'm being presented with this message just when I'm tring to install FSSS.

 

I'm using an admin account, I have the permissions, the msiserver is running ok (I installed other softwares) so I don't know what more I can do (format the server is not an option).

 

Does anyone have any idea of how to solve this?

 

Thanks!

Answers

  • Hello FelipeO,

     

    Please be informed F-Secure Server Security is not supported on Windows Server 2012 datacenter. Below are list of supported systems:

     

    Microsoft® Windows Server 2003
    Microsoft® Windows Server 2003 R2
    Microsoft® Windows Server 2008
    Microsoft® Windows Server 2008 R2
    Microsoft® Small Business Server 2003
    Microsoft® Small Business Server 2003 R2
    Microsoft® Small Business Server 2008
    Microsoft® Small Business Server 2011, Standard edition
    Microsoft® Small Business Server 2011, Essentials
    Microsoft® Windows Server 2012
    Microsoft® Windows Server 2012 Essentials
    Microsoft® Windows Server 2012 R2
    Microsoft® Windows Server 2012 R2 Essentials

     

    For more information, please visit our product page below:

     

    https://www.f-secure.com/en/web/business_global/downloads/server-security/latest

     

    Thank you.

  • DmitriyDmitriy Posts: 212

    Hi,


    @Maslizan09 wrote:

     

    Please be informed F-Secure Server Security is not supported on Windows Server 2012 datacenter.


    It is not explicitly mentioned in the release notes, but Windows Server 2012 Data Center edition is actually supported platform. The problem may have something to do with the core installation. 

    FelipeO: please contact our technical support and provide FSDiag report from the server where the product fails/failed to install.

  • Hello Dmitriy,

    Thank you for the information. 

     

    Hello FelipeO,

    Kindly open a support ticket with our Technical Support and provide Fsdiag report. Please also provide us with screenshot if possible for further investigation.

     

    Thank you.

  • Maslizan09, hello

     

    All my Windows Server 2012 are Datacenter, and F-Secure Server Security works in all of them. I'm having trouble with just this server (and it worked in this server, too).

     

    Thanks

     

  • OK, I will contactthe technical support

    Thanks

This discussion has been closed.