F-Secure Key stopped working after installed Prem

IpadIpad Posts: 3

I had free Key, installed from Apple store. I activated yesterday premium ticket from f-Secure. After installation Key stopped working pressing Key prings only instruction-page to the display

Device is iPad air

Comments

  • BenBen Posts: 2,641 F-Secure Product Expert

    Hello Ipad,

     

    Sorry for not getting back to you earlier.

    Which version of IOS are you running? Version 7.X is having some problem.

    Refer to this thread.

  • TaavettiTaavetti Posts: 1

    I hava same experience > First KEY FREE version works fine (syncronazion was working fine) , but when I get Premium that's works ok in one (windows 7) workstation. Syncronatzion was stop working. When I do syncronazion no error message no nothng (Last Synchronization time stap was not change) I try connect devices  I get only info "Could not connet to the server. Check your Internet connection and synchronization code". Application left down corner there was text "KEY PREMIUM Valid until 4. kesäkuuta 2017" I have version 3.1.106.

     

    Then I uninstall F-Secure KEY application > after that I could not put PREMIUM code there anymore "Validation failed: Could not validate the coucher. This code has already been used or has expired."

     

    PLEASE HELP  me get this KEY applicatoin work.


     

  • BenBen Posts: 2,641 F-Secure Product Expert

    Hello Tavetti,

     

    Could you try to take the latest version available on our ftp into use.

    ftp://FSKEY:[email protected]/

     

    I'll give you further instructions, by private message.

  • IpadIpad Posts: 3
    I have IOS 8.3

    Premium started working after two days, I Didnt do anything, tried just once and program worked, worked after that, hope It keeps working in future, however, everyday I worry, what if Key wont open, what then?
  • BenBen Posts: 2,641 F-Secure Product Expert

    Hello Ipad, 

     

    Thank you for the update. Other premium devices  should allow you to access your password in case one of them fails.

     

This discussion has been closed.