PC 3.0.115 update does not open window

Downloaded, secondly to an invitation, of new version of Key.  Installing witpoutg messages, startup  stays waiting something.




  • ALIDNA40
    ALIDNA40 Posts: 8

    hi ripatti i have a problem updating to the new version becuase of an erroe that keeps apearing 2503 and 2502 and i must say Fsecure community and Managers are of NO help to this problem and do not expect these Fsecure people to help you out Either........

  • Ukko
    Ukko Posts: 3,370 Superuser



    About mistake 2503/2502. Does you certainly sure that your tried to use default Windows mechanism about scannow/repair some of system services (such as re-registred it) and check system drivers by default "check-test", which was provided under some of Microsoft's advices under their Knowledge base about current troubles.


    Most likely.. that it's should be work for you and can be a trouble about .msi-files.


    But.. if you able to check it more.. what will be about any other .msi-installer?!

    Can you install some of them?! Such as.. does it's certainly related just with F-Secure Key .msi-installer or related with any of .msi-installer?


    Sorry for my reply. I not really found current information under your topics previously (maybe I just forget it).


    But current new update for F-Secure Key also comes with new troubles, which probably related with topic-starter's troubles?!

    There can be two visible troubles:


    -> One of them about "temporary" trouble stuck.

    -> Other.. when not available to login with correct master-password (most likely... for users with specific backgrounds about synced-devices and password storage).

  • ALIDNA40
    ALIDNA40 Posts: 8

    thanks for your reply tried many things no luck and it is only related to Fsecure key.

  • Ukko
    Ukko Posts: 3,370 Superuser



    But what about UAC? Does you use it?

    If it's not related with some of specific known trouble-points (which can be fixed with instructions by Microsoft knowledge bases about current mistake-codes and .msi-files).


    What will be if you launch F-Secure Key installer with right-click and with "Run as administrator"? Sorry if you tried it too.

    Maybe there not enough just one try about "one step".


    Also just as example... will be same story or will be installation good.. if.. for example.. you goes to try install 7-Zip software (?). It's also can be comes with .msi-installer and also required administrator rights for installation.

  • ALIDNA40
    ALIDNA40 Posts: 8
    Super Duper it worked finally it worked like a charm, your
    right click run as admin worked, thank bro thank you ..

    p.s the community manager could not even help a helpless person like me and you know what I even tried phoning them and what not and no one could give a simple solution like you have. thank you.
  • VK73
    VK73 Posts: 10

    I've just made the upgrade to 13.0.115 and frankly I am having a disaster.


    I have several devices (2 Macs, a PC, 3 iphones on the same keyring set), and whilst the Mac's work but show the wrong subscription date ie valid until June 2014, the PC app won't open at all, and the iphone I installed is show June 2015.


    Now perhaps I tried to upgrade too many things at once - and I even end up by an addition £10 subscription key in error trying to fix things.

    But I kind of ended up here as all the devices said I could upgrade.


    I have also just take a 5 device sub to mysafe, so not sure if that is  factor too.

  • ALIDNA40
    ALIDNA40 Posts: 8

    hi ben i tried this but the message siad i already had the newer version installed.


    thank you anyway.


    the method i used was given to me by another member here on fsecure i think it was ukko all i had to do was save and run.but not just save and run, first it should be saved then right click run as admin and it will install like a charm with no horrible error 2502/2503 install messages.

This discussion has been closed.
Pricing & Product Info