Cannot logon to Key after SW update

Sasa Posts: 7

My F-Secure Key prompted for an update and I run the update for my two laptops. The result is that I cannot log on Key any more. When I type the password and press enter, nothing happens. If I type some random characters and press enter, I get an "Incorrect password" message. Klicking the yellow key after the password line does not work either with the correct password.


I tried removing Key and the password file from one laptop, re-installed it and tried to sych the passwords from my android phone. This did not work out. When I closed the re-installed key, I run into the same problem again: I cannot login.


This is not about that I had forgotten the password. If I type a wrong password, I get a message that it is wrong. When the password is correct, nothing happens.


So now I have two laptops with updated but non-working key and one mobile phone (Android) with working key (old SW version).


Please help!


  • Sasa
    Sasa Posts: 7

    An addition to my question, my laptops are both Windows. One is Win 7 and the other is Win 8.

  • axmaster
    axmaster Posts: 11

    Hi Sasa, 


    I have the same problem! (see my post regarding the same problem). I used the 'repair' button a couple of times, then reinstalled twice, but nothing seems to work. Luckily, Key still works on my Ipad and my other laptom (MS Vista). But on my 'workhorst' I cannot use the newest version.


    I hope F-secure will fix this problem soon! 


    If I find a solution, I will post it here. 



  • Sasa
    Sasa Posts: 7

    Thanks! Smiley Happy

This discussion has been closed.
Pricing & Product Info