No login after upgrade to newest version

I'm running on Windows7, 64 bit


Yesterday I installed the new version of  Key on my laptop. However, I am not able to log in anymore. I uninstalled and installed twice, to no avail. The newly downloaded version requires the master password. When I type it in and hit 'enter' it does ..... nothing! No error message, nothing. I know I have the correct master password since I use the same masterpassword on all  three devices on which I have installed F-secure Key (I use premium - I am therefore lucky not to have lost my passwords). On the other two devices I type the masterpassword, hit enter, and I can use Key. 


So the question is, how do I get in the new version? Is it just me, or is there a bug in the new version?




  • Ukko
    Ukko Posts: 3,356 Superuser





    Sorry for my questions.


    - Other two devices also with new version of Key under your laptop and with Windows version?! Or it's can be that other devices with previous versions of Key or with mobile platforms.


    - I maybe have same experience, but it's a little be another one. And can be that.. your description related with next steps:


    --> you add master-password/phrase to form.

    --> choose "Enter" (keyboard).

    Nothing as result.

    --> you don't try to use "mouse" or "touchpad" for entering-action (?!).



    If it's like that. Most likely.. that with "mouse/touchpad" action for entering to Key (as key-picture logo related) you can to use Key, but probably it will be with "briefly" visible password and "nothing" after that. Such as "clean" installation. For that.. you have to use "lock" feature or will use "Enter" by keyboard. But time to time.. it's not work..... and looks like maybe not work with first use always (?!).

    But maybe you have something else. 

    But OK... probably you have something else, than was under my suggestion.

    Maybe you can try to do something as: launch installer again and choose option "Repair".

    Or just wait normal response from F-Secure Key team.

  • axmaster
    axmaster Posts: 11

    Thanks for your response Ukko!


    I tried the ´repair´ before reinstalling. That didn´t help either. Another forum member (Sasa) seems to have the same problem. 


    I hope the good people from F-secure respond soon. 



  • KMarttinen
    KMarttinen Posts: 1

    For me either! It does notjin when I try to enter my master password. Test your updates better!!!!!!   

  • Sekor80
    Sekor80 Posts: 3

    Exactly the same problem! Help, something is wrong with the update.

  • Sasa
    Sasa Posts: 7

    Hi F-Secure support,


    I'm one of those who are suffering this issue (Win 7 and Win 8 laptops, luckily I have not updated my Android smartphone).


    Can you please confirm if you have seen this discussion and if you are aware of this issue in the Key SW. Now there is a small doubt whether the problem lies in the application or at the user('s devices). I tried uninstalling and re-installing Key once more today but this did not help.


    I'm fine if you do not yet have  fix for this and if you do not know how long it will take to fix this. Just a notice on that you are aware of the issue and are working on the fix would be highly appreciated.




  • Ben
    Ben Posts: 2,641 F-Secure Product Expert

    Hi All,


    Sorry for not coming back to you earlier. Our developper is working on that problem currently. 

    We are trying to get it fixed as soon as possible.


  • kiljander
    kiljander Posts: 49

    Sasa and others,


    Thanks for your clear feedback of the mis-behavior with the latest KEY Windows update. We have registered the feedback and our Windows developer is working on it. We will keep you posted.




    Harri Kiljander

    KEY team

  • axmaster
    axmaster Posts: 11

    ...good to hear F-secure is working on it. I did notice an update of the Ipad app. 'By mistake' I updated the app and it seems to work fine. (With 'by mistake' I mean that considering the bad Windows update it would probably have been smarter to wait a week or two to make sure the IOS app was working correctly. @f-secure.... don't make me loose my trust in you....)

  • axmaster
    axmaster Posts: 11
    Login to Key seems to work on Windows 7. Thanks F-Secure!
This discussion has been closed.
Pricing & Product Info